Where is the 'foreign language translation' option in Dev?

Can you try toggling it off/on again?

Thanks but toggling off & on had no effect.

Just to be sure I understand how the translation extension works, I shouldn’t have to manually activate it to translate a webpage, correct?

When I just did that the page redrew with translation, but then quickly disappeared with some intervention (‘error’ screen) from the website about an ‘ad blocker’ it seems to be objecting to.


“Adblocker ganz einfach deaktivieren”

I don’t have any ‘ad blocker’ extensions loaded in Brave. Is it perhaps objecting to one of Brave’s shields?

Hmm I a little perplexed myself now. When testing on the site you just linked to, I was not offered to translate the page – which I believe is the intended functionality. I’ve contacted some team members to confirm the functionality.

That said, I was able to manually click on the extension and select Translate this page, which worked just fine. Will return when the team gets back to me.

OK thanks. Sounds like you did the same thing I did (i.e., triggering the extension manually) but for some reason, unlike me, you weren’t interrupted by the Ad Blocker police.

Mozilla is working on client-side page translations.So things would get translated locally without the need to send it off to a third-party server.

1 Like


What I’m finding is that ‘manual’ translations work on the current webpage, tho I’ve seen no evidence of any ‘auto-translate’ functionality.

However, as soon as the current webpage is altered (e.g., input causing a redraw) it reverts to the original language – meaning that translation has to be continuously triggered manually.

Another instance of a foreign language webpage neither auto-translating nor prompting for yes/no user input:


In this case, no manual options worked either. The “Translate this page” prompt is a bit confusing because one doesn’t know whether to just click on it or first enter the same URL of the webpage that’s currently open. I found in the past that just clicking on the prompt triggered the translation.

But this time that didn’t work, nor did first entering the webpage URL and then clicking on the ‘Translate’ box to the right of it. Even the ‘Open in Google Translate’ option only displayed the page URL, not the webpage content.

Maybe there is something about the formatting of ‘web.archive.org’ webpages that renders them incompatible with the translate extensions (?)

This could certainly be true, however I seem to be able to get the translate function to work:

Thanks, I’ll take a look at the web archive page again. I assume you meant that the behavior re translating that webpage was no different than for any other.

That issue aside, I have not been getting any automated translation (i.e., it always has to be manually triggered) or any prompt asking me if I want the page translated.

And as I mentioned in an earlier post, if I click on any clickable element on a translated webpage it reverts to the original language.

@Mattches I tried that German webpage again. This time it did work, after a long delay. Normally, when I click on the ‘TRANSLATE THIS PAGE’ dialog box the translation follows pretty quickly.

I still don’t know why BILD.DE thinks I have an Ad Blocker. Is there a particular Shield that I might try disabling to test whether I still get the error message? (I don’t see a shield specifically for ad blocking.)

And I also still haven’t seen any ‘automatic translation’ or ‘prompting to translate.’

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.