When I press unverified Brave Wallet popup comes up but when I press Uphold nothing happens

Briefly describe your issue: – Raised this topic before but have not been able to get a solution yet. –
When I press the “Unverified” button in the Rewards page to verify my wallet I get o popup to choose Gemini or Uphold; when I press Uphold nothing happens; no pop up , no link nothing. How do I verify my wallet? It used to be linked to Uphold and sometime in 2021 it stopped being linked.

**What Operating System and Brave version are you using (Menu --> About Brave)? Mac OS V12.4
Brave 1.42.97

**Is your browser wallet currently verified? (yes/no)NO

**What date did you verify your wallet?2019

**Have you been able to successfully receive payments in the past?Yes until March of 2021

**Are you using a VPN? (yes/no)sometimes; makes no difference

**Are you in a supported region (see here for list of supported regions)?USA , so yes

**Have you manually turned off Auto-contribute on all of your devices linked to Uphold??NO

If your region is not supported, what you can do is set up creators profile and send bat to your linked creator socials then once you have your bat there in creators section, it will dump bat in your account when the settlement happens. I prefer to use Gemini, when you link the creators page with gemini it works for me.

I suggest you open a support ticket.

Yeah, something like every 90 days it unlinks you. It’s meant to be a security feature.

Let me verify your steps and what you’re doing. So you start off step 1 by going to Brave Rewards from settings, right? In which case you see something like:

You then click on Unverified and hit `Continue when it pops up to say verifying is optional.

At which point you are presented with the part where you click either Uphold or Gemini. And no matter where you click, whether it be on the name or the black arrow, it doesn’t do anything?

I know when I click on Uphold, it then goes to the screen we see below:

It might appear like nothing changed, but look to the left. Instead of being blank, it now says there’s the 2 BAT minimum balance and now a link that says Continue to login is available. To proceed, I have to click that Continue to login link.

From there, it takes me to Uphold where I’m able to complete the login process.

Can you tell me where it’s “breaking?”: Or is it that perhaps you didn’t see the login link on the left?

Hi, thanks for your response!

So when I press Uphold button (or Gemini for that matter) it does NOT show the “Uphold requires a minimum…” on the left. the button is highlighted but nothing happens
marc

Try to shut off the shield, it gives problems with the Uphold site.

Hi, just tried it and it did not work.