What can I do to make Brave load faster in Windows 10

Description of the issue:

I’m running V0.66.101 of Brave on my Windows 10 Pro version 1903 PC. This morning after my PC was started and everything else had fully had a chance to load I opened an email and clicked on a hyperlink to read a ZNET article. Upon clicking on the hyperlink the screen turned white and stayed white for what seemed to be an rather long time before displaying the menu bar on a black background before rendering the page. Once I reviewed the page and closed the browser I clicked on another hyperlink 30 minutes later and Brave immediately rendered the page. I was thinking that this might be Brave taking a long time to load the page and that the problem could be at the source of the page but I’ve also seen this same behavior and different times of the day where I just wanted to open the browser and just want to open a page based on a search. The problem I have is that I cannot readily reproduce this behavior on demand… So my question to you is whether there’s something in the settings that I have inadvertently turned off that’s causing this that I could change to cause Brave to load faster?

@Moondoggy,
First – dope user name.

Not a whole lot to do on the Brave end really but there are some things that may help.

  • How many (if any) extensions do you have installed? Try disabling them and launching Brave and see if it effects startup time.
  • Have you cleared your data/cache recently? If not, do so and see if this improves performance.

I don’t have any extensions installed to my knowledge it’s just Brave setup to block ads and trackers. Apparently it has been a long time since I cleared everything so after I’ve cleared everything we’ll see if that changes the behavior…

1 Like

@Moondoggy,
Sounds good – please let me know what you find out. Very interested to know if this may be related to a couple similar issues I’ve seen reported lately. I’ll leave this thread open for now, thank you again for reporting!