Webtorrent in Incognito Mode

Description of the issue:

I don’t know if it’s a feature or a bug that webtorrent won’t work in incognito mode.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. In Incognito mode go to IPleak.net
  2. Scroll down to about the middle of the page and click the “add this magnet link”. Note: Any torrent link can be used to reproduce, this one is just one I know.

Actual Result (gifs and screenshots are welcome!):

An error message saying “Requests to the server have been blocked by an extension”

Expected result:

Launch of Webtorrent with an option to Start Torrent

Reproduces how often:

Every time that I’ve tried

Brave Version(about:brave):

0.56.12 Chromium: 70.0.3538.77 (Official Build) (64-bit)

Additional Information:

Apologies for not using the appropriate template initially.

Please repost (or edit your original post) to reflect the template and guidelines and we’d be more than happy to assist you.

See above. I edited the post to reflect the template/guidelines.


@Mattches @Joeolson, AFAIK, extension need special permission to run in Private Window which can be enabeld in Settings. Same behavior with Chrome.

But I’m not really sure about the built-in Torrent viewer (webtorrent). Since it’s not listed as extension, IIRC.

And fwiw, I don’t have any extensions installed that run in private windows. So not sure what extension would be preventing it from working.

Since extensions in general are blocked in private/tor windows I imagine Webtorrent will be blocked as well. Not sure if we plan on addressing this given that private/tor windows shouldn’t be allowing outside connections.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.