Websites showing ads even with all adblock filters!


#1

Two Swedish sites are still showing ads with adblock on, i have tested with all filters on the desktop version of brave and it still shows ads. There are no ads on the iOS version of brave and no ads when using chrome with adblock/adblock plus. Expressen is the worst, you can remove some ads by using swedish fanboy but not all… Thanks in advance!!!

he two sites are:


http://www.aftonbladet.se/


#2

Thanks for reporting @Jacalz
Can you please confirm your OS, and if you have Flash enabled in Brave?

We’ll investigate these two sites on desktop, and will follow up with an update once resolved.

Stay tuned


#3

I was using macOS El Capitan and I had the same problem both with and without flash but I mostly had it off :smiley: Thanks for a fast answer :wink:


#4

@Jacalz thanks for the quick response. The info is very helpful!

Really appreciate your participation here in the community. Your contribution is helping to keep Brave users more protected. :smile:

Please do continue to make these reports as you encounter any issues like this in the future. We’ll be sure to follow up following the investigation and resolution.

I might request you to check as well once we have a fix pushed just to ensure that we fully covered off in your geo.

Stay tuned, -Luke


#5

Great, keep up the good job :wink: I will let you know if the fix worked when it’s ready :slight_smile:


#6

Hi i noticed a new very strange issue on these websites!
I tested if i had the same problem with my pc running windows 10 and brave 0.13.0 and the ad issue is not there but the website just doesent want to update to https it just says that i am using a insecure connection… I have tried to turn on and off the brave shields but it doesent work.

Really strange i have restarted the browser and tried all those things you may suggest to a noob :wink:


#7

Thanks for reporting this @Jacalz!

I’ve created this issue in github for the original report:

I’ll be updating to include this info so we can investigate further.


#8

Great, Thanks :sunglasses:


#9

Just wanted to update you on the fact that the ad problem is half fixed on the new update (0.13.1) and it still does not update to https. I tested on MacOS Sierra, El Capitan and on Windows 10! It was the same on them all. :wink:
I included two screenshots to show how it looks :slight_smile: You can see that there are still two white boxes where the ads would be and it says insecure connection at the top still. I know that you didnt say that you fixed it but yeah i wanted to let you know :wink:


#10

This is really great to hear @Jacalz

We have an open item for the white-space issue, but glad you pointed it out.

I’m also glad to hear the ads are not showing up, which is great news!

A couple of things I noticed:
-It looks like the aftonbladet site does have https available, but may be doing some redirecting by default to insecure. I’m going to add that to the ticket as an item to investigate further.

-I’m unable to see the ads too, which is good to see.

-It looks like expressen.se does not have an ssl cert for their domain, so is redirecting from a manually entered https:// url back to http://. There isn’t much we can do about that, since the publisher will need to upgrade to get the SSL certificate and allow for https:// for their domain.

When I test these, a good way to determine if a site has http or https is to manually attempt to upgrade or downgrade by changing http:// to https:// and vice versa (with https everywhere off). Then, if you see that a domain has https://, I switch https everywhere back on to see if there might be a hiccup in the feature. :slight_smile:

Will put some time into double checking this further, but thought the info above might be helpful.


#11

@luke.mulks Ok here I am again after all this time to say that the issue is back again for me in 0.13.4! :grimacing:http://aftonbladet.se” shows a big background ad that covers the whole background and some times there is a big ad square covering the whole screen without any ad in it, that you need to click on an “x” to remove :confused: I will give more info tomorrow and some screenshots for you :wink:


#12

Thanks @Jacalz!

Will investigate this further as well.

If you’re comfortable/familiar with the DevTools in the browser, if you can take a look in the Network tab within devtools and see if you’re able to ID the script that is being used, that would be awesome too. LMK if you are familiar w/this process, I’m planning on putting some docs together for the community and am trying to gauge how comfortable/familiar people are with using devtools.

Thanks again for your ongoing contributions to Brave! :slight_smile:


#13

I am sadly not any good in the networks tab and not with js either, I know a bit HTML and CSS but not more :grimacing: But I would be happy to try if you just tell me where to look in the networks tab :wink:


#14

Back again with some info for you :smile: @luke.mulks
It happends on both Windows 10 Home and Pro and on Mac OS X 10.11.6 (El Capitan) and 10.12.3 (Sierra) but does not happend every time, some times it is there but sometimes it always blocks all ads :wink:
I could not get it to pop up today on my Win10 Pro pc but I managed to do it yesterday and on mac os X :scream:
This very big leovegas.com ad is kinda disturbing :sweat_smile:


Sometimes I get this half empty ad to pop up:


#15

Thanks @Jacalz!

Appreciate the info. That’s a weird ad Indeed :wink:

Will dig into this today, and provide an update.

Thanks for the info about dev tools too, I will put together some easy directions on how I hunt for these that might prove helpful. It’s pretty neat having these tools built right in, and I bet you will find yourself using them quite a bit once they become familiar.

Stay tuned!


#16

Might be good if you update the issue on github with this new info and suggest you to put the guide in the blog page at brave.com :wink: I really apreciate the work you do and I really have got addicted to helping people in this community :smile: It just feels so damn good :blush:


#17

Ok, here is a update to you about http://expressen.se/:
Very rarely there is a full screen video that pops up and you need to click it away :wink:
Looks like this:


#18

Definitely will do! I am going to start a section in the wiki on Github dedicated to hunting down ad issues, and will have the dev tools guide be the first addition to it.

It’s been awesome seeing the activity. You’re helping us blaze a trail here, and our team is really grateful to have your ongoing support in the Community!


#19

Haha, thanks :blush: I have the big leovegas ad open on my mac with the devtools open, is there any way I can share the info from the devtools with you? I mean if you cant get the ad to load :wink: It seems to be very random :sweat_smile: @luke.mulks


#20

Quick question…

Can you see if you have regional blocklists for your area applied, by entering about:adblock in your URL bar.

There is a SWE: Fanboy's Swedish blocklist option that you can toggle.

Would you mind toggling that, and refreshing the domain so we can see if the regional blocklist resolves?

Will get you some info on the dev tools, and will be investigating from the US shortly.

Thanks!