Website broken because assets getting blocked

Description of the issue:
Website https://lnkd.in/interstitial is broken because assets from licdn.com are being blocked by brave browser. Both lnkd.in and licdn.com domains are owned by LinkedIn.

Exact URL of the website in question:

Did the issue present with default Shields settings? (yes/no)
yes

Does the site function as expected when Shields are turned off?
yes

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
no

Does the site work as expected when using Chrome?
yes

Brave version (check About Brave):
v1.48.171

Have you tried with Brave shields down?

Yes, as mentioned in the post, it works with shields down but the problem is that brave is treating LinkedIn’s cdn as a tracker on a domain (lnkd.in) that’s owned by the same company.

You enable Allow LinkedIn embedded posts in brave://settings/socialBlocking

That’s the reason for that social media blocking page, when toggles are off/disabled, those network request will get blocked by the Brave social list, by the rule (in this case): ||licdn.com^$third-party,domain=~linkedin.com

Thanks for explaining. Can this rule be updated to include lnkd.in domain as well since.

For context, linkedin uses this domain for our shortlink service. When a user clicks on this url, we redirect users to third party sites. For safety of our users, we are adding an interstitial page for these redirects so that users have control and visibility on where they are being redirected. example: http://lnkd.in/interstitial But this page is broken because of the rule you described. Until now there was no UI page being served from lnkd.in due to which this issue was never discovered.

This rule should include domain lnkd.in as well.

Should fix this.

Thanks @fanboynz for fixing this. What’s the timeline for the change to be available in browser?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.