Website autoplaying video(-ads) with autoplay blocked

Description of the issue:
on welt.de, they autoplay videos (with ads!) despite me having blocked autoplay.

Exact URL of the website in question:
for example on this article:
https://www.welt.de/motor/article132620014/Sechs-Winterreifen-fallen-bei-ADAC-Test-durch.html

Screenshot of the ad as it appears in Brave

Did the issue present with default Shields settings? (yes/no)
yes.

Brave version (check About Brave):
Version 0.70.122 Chromium: 78.0.3904.87 (Offizieller Build) (64-Bit) on Mac

Even if the ad was a first-party ad (which I’m not even sure it is), it still shouldn’t autoplay (even with sound!) when I have autoplay disabled.

Hi @BraveNew - thanks for reporting. Same thing is happening to me. @fanboynz, would you mind taking a look at this is you’re available?

1 Like

Yeah the autoplay issue occurs in Chrome also, Firefox seems to work better in this regard. Possibly an issue with Chrome method of blocking auto-play. I guess a quick fix for the time being would be just toggle the “autoplay” on the site.

Just needs to investigated further regarding Chromes autoplay.

https://bugs.chromium.org/p/chromium/issues/detail?id=1022721

@fanboynz
in the chromium forum, they said it is resolved. it isn’t.
I just tried out my link from OP again. This time, while no ad played, the video related to the article still started playing automatically despite me having blocked autoplay in Brave.

Yeah I pulled it, seemed it wasn’t reproducible in Chrome. Its probably due to the fact we’re blocking some ads.

Hi @fanboynz,

I am experiencing this problem on the mobile platform version 1.5.2, Chromium 78.0.3904.108 for Android 8.1.0

Go to Nypost.com
select link https://nypost.com/2019/11/24/yankees-bust-greg-bird-could-get-chance-to-save-career-with-red-sox/

On desktop brave, the autoplay does not occur for the video above the article
However on mobile brave, the autoplay does occur for the video above the article

mobile site settings:
Media - protected content blocked, autoplay blocked, video playback in brave blocked

please advise. thank you.

Hi @fanboynz, I didn’t receive a response from my last issue and this topic will close in 3 days. Please advise me what to do.

@2019Tester2,
If you tap the “lock” icon on the left side of the address bar then select Site Settings, what permissions do you see granted for the site?

@Mattches,

Sound (block)

  1. Tinychat.com
    As Admin mode - playing yt videos the following blocking:
    https://cdn.cookielaw.org/consent/044ebf65-2f51-464f-a89e-e8745b296670.js
    https://dev.visualwebsiteoptimizer.com/j.php?a=281741&u=https%3A%2F%2Ftinychat.com%2F4everfr1ends%23signin&r=0.8854044049859751
    https://widget.intercom.io/widget/m782hxb5
    https://secure.adnxs.com/seg?add=3083006&t=1
    https://www.googletagmanager.com/gtag/js?id=AW-701105856
    https://ssl.google-analytics.com/ga.js
    https://secure.quantserve.com/quant.js
    https://script.crazyegg.com/pages/scripts/0003/6083.js?437613
    https://m.stripe.network/inner.html#url=https

  2. Infowars.com/watch-alex-jones-show
    Duznt even show the “play” icon the following blocked:
    https://cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.0.3/cookieconsent.min.css
    https://cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.0.3/cookieconsent.min.js
    https://d31qbv1cthcecs.cloudfront.net/atrk.js
    https://connect.facebook.net/en_US/fbevents.js
    https://directus.libertycdn.com:8080//items/infowars_ads
    https://p.typekit.net/p.gif?s=1&k=smg7rbp&ht=tk&h=www.infowars.com&f=139.140.175.176&a=1700625&js=1.19.2&app=typekit&e=js&
    =1575409079475
    https://directus.libertycdn.com/_/items/billboard_video_ads?filter[enabled][eq]=1
    https://onesignal.com/webPushAnalytics
    https://embed.infowarsmedia.com/videojs-event-tracking/dist/videojs-event-tracking.js
    https://s.yimg.com/wi/ytc.js
    https://www.googletagmanager.com/gtag/js?id=UA-6888464-2
    https://www.google-analytics.com/analytics.js
    https://secure.quantserve.com/quant.js
    https://static.hotjar.com/c/hotjar-1149050.js?sv=6
    https://www.googletagmanager.com/gtag/js?id=AW-824721487
    https://secure.adnxs.com/seg?add=7947442&t=2

I understand its Some or Someone of deez thats blocking but i hav no idea how to disable just a few :thinking: :v:

@2019Tester2,
Can you try tapping the Clear and reset option (Lock icon --> Site settings menu) for the site and try again to see if autoplay is blocked?

@Mattches, after doing what you requested, the autoplay for the site was blocked. Thank you for your time and help.

1 Like

@2019Tester2,
You’re very welcome :slight_smile: