Webs with a pop-up or banner asking to accept cookies is blocked

Description of the issue:

iPad iOS 17.0.3 + Brave 1.57.2. Every web with a pop-up or banner asking to accept cookies is blocked. The cause: Brave doesn’t allow neither to accept nor reject them; it doesn’t allow to interact with the form. So, every web asking to confirm preferences is unreadable.

How can this issue be reproduced?

  1. Loading any european website with a banner/pop-up requiring cookies consent

Expected result:

You will be unable to accept/reject/modify/interact with the form and the page will be unreadable. The page will be frozen and you will have to reload it to repeat the experience. Or, you could press the Speedreader button and maybe, just maybe, you can read all or part of the article (missing graphical elements or interactivity).

Brave Version( check About Brave):

Brave 1.57.2.

Mobile Device details

iPad iOS 17.0.3 (iPad iOS 17.0.2 too)

Additional Information:

Is this caused by internal settings in Brave or is it because of the last updates? Could it be solved easily or it is a bug and we need to wait for a new update?

1 Like

@Pepepotamo have you checked your settings? If you go to Brave’s SettingsBrave Shields & Privacy and check all the toggles, you’ll see one of them is Block Cookie Consent Notices.

That said, none of the sites should be broken by it. So it would be good if you can share links to websites you have broken.

Other thing is I’d honestly say while you’re checking the settings, you pop into Content Filtering and enable Fanboy's Annoyances, uBlock Annoyances. And then I do keep the EasyList Cookie filter running, which is what the toggle for Block Cookie Consent Notices will turn on or off.

In any case, it’s always good to create topics here in places like Ad-Blocking if you see that Shields settings are causing sites not to work right. When you report it, the teams are able to investigate and adjust code to make sure everything works properly while doing the best as possible to keep your privacy and reduce annoyances.

1 Like

Same here. I am currently using iOS 17.0.3, Brave updated to the latest version. I haven’t been able to get past that cookie screen for weeks. Did what suggested in the answer, but nothing seems to change.

If it matters, I am in Italy.

@ditti important part is to share what websites you’re trying to visit so things can be fixed.

When you say you did what was suggested, as you saying you turned off the toggles on things like Block Cookie Consent Notices? Or even tried with Shields off to check? I’m assuming it’s Shields interfering, especially if you have it set to block cookie notices.

Hey there!

I tried both. Toggles on or off, nothing changes. The cookie notification appears, but it’s unclickable. It goes like this on every website I try to visit for the first time (or I visit after a long time).

For example, this local newspaper: www.ilcentro.it

Give 24/48hrs. for the fix to roll out.

1 Like

Woah, thank you very much!!

Same here, it’s not one particular website but any that have the ‘accept/reject’ cookies pop up. I have visited the same websites/pages with Duck and the pop ups can be answered and then I can read the pages.
Currently this makes Brave unusable for me so I’ve moved to Duck.
As others are having this problem on other sites then it’s a Brave issue. Be pleased if Brave can fix it but for now I’ve moved to another default browser.

@C33 you should see from discussion above that you need to provide more information to get things resolved.

It’s all been said above.
Whe. You go to a website that instantly has an accept/reject cookies pop up you can’t, that is the screen is frozen and the accept reject banner doesn’t respond to and screen pressing.
Here’s two:


On this one, I didn’t get the cookie consent notice. So it seems like Shields is doing its thing or something.

And on this one, express.co.uk I see what you mean that hitting anything does nothing, eventually just refreshing. I can bypass the notice and interact with the site by enabling Block Scripts but that’s about it. I’ll tag in @fanboynz so he can check out both and possibly get the team to make adjustments.

If you see any other websites, please share them so we can look into it and get scripts adjusted to make sure they will work properly.

express needs additional work, xcweather a fix is on its way. Give it 24/48hrs

Hello!
Same issue. If I turn shields off for a site, it will work. If I turn on auto cookie consent supression, it too will work. But I dont’t want to use those, as I’m usually selective about cookies, I consent to a small minority on some sites and reject the rest, but the supression is a blanket solution.
Example sites: www.telex.hu, www.infostart.hu, index.hu. All seem to be using the same type of cookie consent notice, which is pretty popular at least here in Hungary.

Turning shields off, selecting cookie options then shields back on works.
Thank you!

Fixed index.hu, but the other sites are already covered @Vacip

Added a few more .hu sites (around 30 or so sites)

can you do the same for https://ekstrabladet.dk/?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.