"WebRTC IP Handling Policy" stuck on "Disable non-proxied UDP"

Last night, I updated Brave to Version 0.65.121 Chromium: 75.0.3770.100 (Official Build) (64-bit), on Windows 10 Pro, 1903.

I previously had WebRTC IP Handling Policy set to “Default”. Now it is set to “Disable non-proxied UDP”. When I try to set it to “Default”, after I reload the Settings page, it is back to “Disable non-proxied UDP”.

To reproduce, go into Settings -> Additional settings and set “WebRTC IP Handling Policy” to Default. Then reload the settings page, and the policy will be back to “Disable non-proxied UDP”.

Here is a GIF of what I see:

I discovered the cause of this problem. uBlock Origin has a setting called “Prevent WebRTC from leaking local IP addresses”. When this is enabled, apparently, it forces Brave to set “WebRTC IP Handling Policy” to “Disable non-proxied UDP”. When I unset the option in uBlock, Brave behaved as expected.

This topic was automatically closed after 30 days. New replies are no longer allowed.