WebRTC Block for 2017

windows

#1

Is there a way to disable WebRTC on windows?

I know there was on update recently but I still cant find a way to disable WebRTC.


#2

Brave doesn’t leak WebRTC on Linux. I’m running a VPN & I get a quick check on things by using the following website:

For more depth I use:

https://browserleaks.com


#3

@Bespoke I’ve just installed Brave on my Win7 machine & tested it with ipleak.net & there is NO WebRTC leak.

So from my own personal experience now with both Linux & Win7, plus with Alex (Brave employee) liking my previous post. I think that it is pretty safe to say that WebRTC is OFF by default thanks to the dev’s. :smiley:


#4

+1 for Brave :smiley:


#5

I appreciate all the comments.

According to ipleak.net I have no issue. However with browserleaks I get this;

RTCPeerConnection :heavy_check_mark:True
RTCDataChannel :heavy_check_mark:True
ORTC (Microsoft Edge) ×False
IP Address Detection
Local IP Address n/a
Public IP Address n/a
IPv6 Address n/a
WebRTC Media Devices
Device Enumeration ×False
Has Microphone ×False
Has Camera ×False
Audio-Capture Permissions ×False
Video-Capture Permissions ×False
Unique Device ID’s n/a

On other browsers the RTCPeerConnection and RTCDataChannel will say “False”.

Why not Brave? Is WebRTC still off?


#6

On browserleaks.com all categories display false or n/a except for the below items which display the following:

RTCPeerConnection :heavy_check_mark:True
RTCDataChannel :heavy_check_mark:True


#7

This is my experience as well.

I tried to post that but the system temporarily blocked it.


#8

HI @handy I know it’s off topic but do you use a proprietary VPN client provided by your service for your particular Linux distro or are you using a browser based solution?


#9

@Numpty I use AirVPN on both Manjaro & Win7. There is a GUI that you can use if you want to (I do) that makes setting up & configuring Air (if you want to & know how - in some depth though you don’t need to change anything). I install the GUI via the Arch User Repository (AUR), though it is available for a number of different OS’s as a standalone package from the AirVPN website (opensource of course :wink: ).

So the Air GUI is called Eddie (I likely spelt it wrong) & it runs completely independent of your browser. Which is great, as you can use qBittorrent & the like via a port that you have allocated when using port forwarding on the AirVPN website.

I have Win7 setup to automatically (also via Eddie) start Air when I log in (the choice is available in Eddie). I have Manjaro start the Eddy GUI automatically when I log into Openbox & then I manually lock it to the AirVPN DNS (if for whatever reason you loose your internet connection to the Air server you are using, you remain locked to their DNS so you don’t become vulnerable to being tracked). Then I tell it to connect to the optimal server at the time.

I do the manual thing with Manjaro as it uses the Arch Linux rolling release system for package maintenance. So I check if there are any upgrades available & then download & install them before I start using AirVPN, as there is a performance hit (usually not much) & I know I can trust the Manjaro upgrade system.

I’ve used Air for 3 or 4 years now & I’m extremely happy with their service. If you have any need for technical support (most likely when someone is initially setting up, or if they have an unusual system - you don’t have to use Eddie, you can do it all via openvpn & such), they contact you pretty quickly. Also, they have a forum that is extremely useful & has a great attitude. It is closely observed by Air staff too.

If you are using a well known distro it should be no problem to use Eddie (the quick easy solution).

@Bespoke re. your query about your browserleaks.com output. I think that is fine. For me the really important parameter there, are:

IP Address Detection
Local IP Address n/a
Public IP Address n/a
IPv6 Address n/a

[edit:] Sorry guys, I made the odd typo in the above. I’ve fixed it up now, so it should be a little easier to interpret. :wink:


#11

#12

I forwarded your question to https://github.com/brave/browser-laptop/issues/10592

thanks


#13

Closed in favor of How do I turn on Browser Fingerprinting Protection and make sure that it's working?