Webpages take forever to load

Why is Brave so slow when loading webpages? It takes a few minutes for each website to load. With or without Shield.

@siciliangal ,

In general, burdens are caused by:

  • computer [gear] problems
  • network problems
  • excess processes [including extensions installed]
  • firewall software [and possible multiples of that]
  • a variety of flags, options, preferences, settings, and switches . . . and the possible combinations of those . . . including scripts . . . with either textual settings or ON / OFF positions
  • bugs in one or more applications (and / or sub-routines)

In order to help diagnose, tools:

Apple Mac OS:

  • Brave Browser Task Manager
  • Brave Browser Developer Tools > Network
  • Activity Monitor.app
  • Console.app
  • Terminal.app command line

Windows OS:

  • Task Manager
  • Brave Browser Task Manager
  • Brave Browser Developer Tools > Network
  • Windows Command Prompt / Windows Shell command line

Linux OS

Given all that, the user will do well, to provide a detailed report on the conditions.

How to use Developer Tools > Network

https://www.lifewire.com/web-browser-developer-tools-3988965

https://developer.chrome.com/docs/devtools/network/reference/

https://docs.microsoft.com/en-us/microsoft-edge/devtools-guide-chromium/

Some methods that might fix things, follow. You do not have to run all of them at once.

How to flush DNS cache in Windows OS:

https://www.wikihow.com/Flush-DNS

How to flush DNS cache on a Mac

In a Terminal.app window, enter at the prompt:

dscacheutil -flushcache

You might, for testing purposes, look over the “Secure DNS” settings:

“brave://settings/security?search=secure” (no quotes)

Perhaps try some of the Custom Providers.

Try . . .

Clear your browsing data

In a New Window, go to:

“brave://settings/clearBrowserData” (no quotes)

Click on “Advanced”

Change “Time range” to “All time”

Select all three of:

  • Cookies and other site data
  • Cached images and files
  • Site and Shields Settings

and click the “Clear data” button.

And, another set of steps . . .

Clear host cache, close idle sockets, and flush socket pools

In a New Window, go to:

“brave://net-internals/#dns” (no quotes)

and click on “Clear host cache”

In a New Window, go to:

“brave://net-internals/#sockets” (no quotes)

and click on both

  • “Close idle sockets”
  • “Flush socket pools”

Restart Brave Browser.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.