Web console doesn't load after login to Cockpit web console

Description of the issue:
I can’t access my Ubuntu Server’s Cockpit admin Console page through Brave.
Every time I log in I just get a blank white page (screenshot)
I can see a brief message showing: "Please enable javascript to use the web console"

I went to the Shield settings and disabled “Block scripts”. I also went deeper into security settings and allowed the domain.
Javascript is enabled in settings
I can get to my Cockpit web console using Edge (windows) & Brave on iOS.
I tried a fresh Brave install, but the issue remains the same.
I also tried it after deleting cache/website data.

Actual Result (gifs and screenshots are welcome!):




Expected result:
Enable JS to view the web console or other solution
Reproduces how often:
Every time
Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 - Brave [Version 1.24.86 Chromium: 90.0.4430.212 (Official Build) (64-bit)]

Additional Information:

@Saidou,
Thank you for reaching out to us. So I would actually imagine this issue is due to one of the extensions you have installed. Can you try opening a “guest” window and see if you van view the web console using the guest window (which will have no data and no extensions installed) and see if you get the same results?

Thank you @Mattches for your reply.
I suppose you mean to open a Private window? Tried that already before, but just to make sure I tried it again, but that doesn’t solve the issue…

@Saidou,
TBH I think we should probably try with a fresh profile to be absolutely sure – would you mind making a new browser profile and confirm the site still does not load? Also, if you open the dev tools Console window, do you see any errors in the output here (if so please share)?

@Mattches
I deleted the user data folder and started with a fresh install.
Same issue… :frowning_face:
This is what I see in the dev tools Console windows:

Are you using secure dns @Saidou ? (if so, disable).

Does also adding @@||127.0.0.1 and @@localhost into brave://adblock help?

1 Like

@fanboynz, thank you for the suggestions.

Are you using secure dns @Saidou ? (if so, disable).

Do you mean these settings? “brave://flags/#dns-over-https Which one do I need to disable?

Does also adding @@||127.0.0.1 and @@localhost into brave://adblock help?

This doesn’t make a difference…

brave://settings/security?search=dns is this enabled?

Secure DNS was indeed enabled, so I disabled it.
For a brief second it worked, but after logging out and back in I got back to the blank page…
Tried cleaning cache/cookies/shield settings and on a fresh and clean Brave installation. Still the same. Dev console outputs the same errors…

Could you PM me the details so I can test?

I’ve sent you a PM.

Thank you

I got it to work.
Apparently a restart of my PC was also needed after disabling “Secure DNS” :slight_smile:

I cheered too soon :frowning:
After few minutes it doesn’t wok anymore.

Tried in a windows 10 VM and there it seems to work fine.