Watch Later not functioning right


Hello fellow Braves!

This is a problem, I only have (and have had) with Brave.
Here and there, when reaching for “watch later” it redirects to the video instead of (surprise) adding to the watch later-list, and it is really starting to p*ss me off.

1 Like


This is an extremely annoying issue, and I really want it fixed.


Hi @KetaKongen

Can you provide details as per About the Help Me category


cc @Mattches

1 Like

Hi @LaurenWags !

Here it is:

  • Brave v0.23.79
  • Windows 10 v17134.165
  • Ad control; Show Brave Ads, Cookie Control; Block 3rd Party Cookies, Fingerprint Protection; Block all fingerprinting, HTTPS-Everywhere; ON, Block Phishing / Malware; ON - blocking scripts is off
  • Go to, be logged in, watch video after video, and use the “Watch Later” function
  • | Password: braveisawesome



Hi @KetaKongen

Thanks for the video - I’m not seeing this behavior. Let’s see if @mattches can reproduce on Windows (I’m on macOS).


1 Like

I actually can reproduce this…kind of? It looks like the "selectable " part of the checkbox elements are a little hard to hit.I’m not sure if they’ve always been this way though.

1 Like

Hi @LaurenWags,

It’s hard to reproduce, since it doesn’t happen page after page.
It comes out of the blue, and usually disappears after it happens and turn to the next page/video.

You’re welcome,


Hi @Mattches :slight_smile:

Probably. It’s those “out of the blue” type of problem, where the hover-over message where “Watch Later” pops out, is not there. The arrow just changes to a pointing hand.



cc @LaurenWags @Mattches,

Has an issue been made on GitHub?



@eljuno | something you can give an answer to?


Still an issue after the latest updates.

@eljuno @LaurenWags @Mattches


Hi @KetaKongen

Based on the conversation in this thread, especially that it’s out of the blue/not consistent, I think we’ll most likely have to wait until brave-core (the re-write) to see if it’s resolved there. @Mattches what are your thoughts?



Sorry @KetaKongen, looks like I fell off the thread. Thanks @LaurenWags!

So I can confirm that this is still an issue. Here’s a couple gifs to show behavior in Brave vs in Chrome:


That being said I can’t imagine it’s a priority. When we release Brave-core (1.0), we’ll inherit Chrome’s native UI so you should see this and other similar UI based issues to be fixed along with it. I know thats not an ideal answer, but the 1.0 release isn’t that far off and it’s going to be well worth the wait!

In the mean time, if you’d like to learn about Brave 1.0 and what you can expect from it, here’s a few useful links:
Brave Blog by Brave CTO Brian Bondy on development plans for 1.0
CTO Brian Bondy Reddit AMA
CEO Brendan Eich Reddit AMA
Brave release schedule - Github


Thank you for the apology.

I just want everyone’s experience to be one to remember, and not to forget.

I can see that, and will not be a pain in A to any of you, it is just a ticker, unfortunately.
I’ll happily wait :slight_smile:

Thank you both for the answers!

1 Like

Have you tried the new Developer Build?
Its a preview of 1.0 and as far as I can tell this issue has been fixed :slight_smile:

1 Like

No, I haven’t, but I’ll be sure to check it out! :smiley:

That’s sounds fantastic, thank you. :slight_smile:

1 Like


I have tried to install it, and I get error: 1


Can you take a screenshot of the error?



Well… it’s not there anymore. It seems to be my McAfee software that is making problems.

I launched it, and got a quick message saying: Brave is missing API keys, so some functionality will be unavailable - something in that manner.


But you were able to install/use the build?