Wallet 'Unable to fetch fee estimates' on Telos network

Description of the issue:
Cannot execute any transactions using the desktop client wallet. The error ‘unable to fetch fee estimates’ appears on the transaction review screen. I have tried several of the available rpcs listed on chainlist to no avail. This was previously working and seems to only affect desktop clients. Balances display, and connecting to applications works but fee estimation fails even for direct transfers.

Is the issue occurring on a specific network?
Telos Mainnet (40)

What operating system are you using?
Ubuntu 22.04.3
Ubuntu 20.04.6
Windows 10 22H2

Brave Version (check About Brave):
1.62.165
1.63.161

Additional Information:
Works on Android 14, Brave 1.62.165

Having the exact same issue with Scroll. “Unable to fetch gas estimates”

Works perfectly fine on other wallets, but can’t sign any transactions with Brave.

Looking back through the forum here, this exact issue was occuring in last year, and took 2+ months to sort out.

Breaking all functionality and locking funds for 2 months is such a collosal failure. Please fix this quickly, critical issues like these are far too common with Brave.

Thanks @donnyquixotic & @TommyC for reporting.

I have reproduced this error and have logged the issue here: https://github.com/brave/brave-browser/issues/36370

How long until this is resolved? Funds are effectively frozen until a patch is issued.

I would have thought that just be a matter of manually setting gas limit and price if fee estimates aren’t working, but somehow even that’s been bricked.

If there’s a workaround that doesn’t mean waiting for devs to correct their mistake, please tell me.

Hi, has anyone experienced a similar issue while using the sovryn.app? I get the same error “unable to fetch gas estimates” :frowning: manually setting gas limits and price doesn’t work :frowning:

How is there still no response?

Surely there is somewhere else to open a support ticket for an issue this glaring. WTF.

cc: @onyb & @jocelyn

cc: @onyb @jocelyn

seriously how is there now resolution or update yet

@TommyC btw, did mean to ask. I notice that the Github shared a while ago passed 2 weeks ago and it was added to release notes for 1.64. Can you tell me if you’re still having issues or if that did indeed resolve in the update?