Wallet UI Not Loading

Please only post Brave Wallet inquiries in this category – visit the Brave Rewards category for all related rewards issues.

The Brave Team will never ask you for your recovery phrase or private key.

Description of the issue: Can’t see any balances in my wallet

Is the issue occurring on a specific network?
All Networks

What operating system are you using? Apple M1, Ventura 13.0.1

Brave Version (check About Brave): 1.56.20, arm64

Additional Information:

Need more information to figure out what’s going on.

  1. Can you please share a screenshot?

  2. Any errors/logs in the developer console when you visit brave://wallet? You can open the console with the Option + ⌘ + J shortcut.

  3. Can you see the balances in the panel?

  4. Have you tried resetting your wallet and restoring your seed back? Make sure you have recovery phrase backed up before you try this.

I can only see balances in the swap tab and nothing else, no console logs. I’ll try resetting my wallet

If this is blocking you, might be worth trying out the latest Nightly version: https://brave.com/en-in/download-nightly

While I’m not able to reproduce your issue on my similar machine with Brave 1.56.20, fetching of balances is significantly improved in 1.58.x (nightly) so worth a shot.

thanks, resetting it worked

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.