Wallet problems

Which seed phrase are you referring to? If you had Crypto Wallets setup you should be able to migrate to the new one without issues. If you created a new password for import it will create a new wallet

I was using the wallet built into the brave browser, I would access it from the drop down menu in top right.
I had it linked to a dapp which I use to host nodes and now can’t get access to those nodes as the wallet address is new and different.
Any idea how I get my old wallet back?

if you had a 24-word seed phrase, be sure to select to use legacy wallet. Otherwise you’ll completely different accounts for the same seed phrase.

1 Like

Thank you so much, I changed the wallet to crypto wallet (deprecated) in settings and I found my account. I am so relieved, many thanks :pray:

1 Like

I think my problem may be related to this one.

brave://wallet/crypto/onboarding is not working correctly. It detected that I had an existing wallet, but apparently did not import its contents when I asked it to do so. Same result when I choose to restore my wallet using my seedphrase. It just says I have Zero ETH, and ignores all the other tokens I had substantial balances of in my wallet as of yesterday.

I also tried settings to use Crypto Wallet (Deprecated), restarted Brave, then restored again using my seedphrase and it had the same ZERO balance. So that did not work either. How can I recover all my tokens?

@mbolz do you have a 12 seed phrase or 24 seed phrase? If you are importing to the new wallet with 24 words make sure you select Import from legacy Brave Crypto Wallets? else you won’t get the same account restored.

I have a 24 Word Seed Phrase, and I did select “Import from Legacy Brave Crypto Wallet”. I also used the same password for both old and new.

At this point I am desperate to just get all my tokens back into either the new OR the Legacy wallet.

What is the path/filename for the wallet contents? Failing a restore, I may still be able to retrieve the original file from the backup of my filesystem?

Possibly also related - I was able to upgrade the wallet OK but now most of my transactions (DEXes on Fantom) are not going through. I did one successful yield farming transaction, but everything else won’t process. Is there something in settings I can adjust?

Also, I have an OG 24-word seed but was able to upgrade to the new wallet OK, create a new password, (had to), and I have all my coins.

Thanks.

Did you check the blockchain to see if your assets are in there and just not showing up on the wallet? The asset listing was lost, but it doesn’t mean your tokens aren’t there

I don’t know how to do that. In any case the Ethereum public send address that is displayed in the wallet now is different from what it was before. That tells me that the seed phrase may not be properly interpreted. Since I have a backup of my filesystem prior to the upgrade, it seems to me that retrieving the proper files for the legacy wallet prior to the upgrade might do the trick. But I need to know what filenames to restore, and what folder to find them in.

Yes, so you need to try both ways with that legacy button. Reset the account, import the seedphrase with legacy selected. If that doesn’t work, reset, import the account again with the legacy option NOT selected. I hope this works for you

@tsa I did try both of those ways, with wallet resets before each. Neither resulted in the contents of my wallet re-appearing, and both displaying Zero ETH, which should not be true, and also a different public address than I expect to see. I am beginning to fear having lost in excess of $50,000 to this “sneak upgrade”.

Is it possible you have more than one seed phrase written down? Did you ever verify it working?

@mbolz Like Silentassasin, if you go to brave://settings/wallet and switch Default cryptocurrency wallet to Crypto wallets deprecated. You will find your old wallet as it exixted before.

@tsa I do not have another seed phrase.

However I do have a different alphanumeric private key with which I created a secondary account in a newly configured wallet, Then the new wallet displayed my correct token balance AFTER I also added the token listing to the new wallet.

How can I create a new primary wallet using that same private key?

@Aman_M
I did that, as I had stated earlier in the thread, and it didn’t work for me

A private key allows you to recreate an account, not wallet. Tbh, I never trust the seeds because different wallets have different words, and you can see now that Brave Wallet needs to have a legacy setting to deal with the difference. So yes, I always back up my private key for this reason.

To restore an account from your private account, go to brave://wallet/crypto/accounts/add-account

and select import using the private key

@tsa Yes, thank you. That is what I did.

However an additional account will not be backed up as part of the wallet for later restoration using the seed phrase… there are still some minor hiccups, but I now have access to my missing tokens again. Thank you everyone for your input and assistance.

1 Like

I have the same problem, when I logged into Brave wallet asked me to upgrade, clicked on button, asked for new password, now wallet is showing but only has my Ethereum showing. No other coins showing even when I put in contract addresses. Seem to have lost access to all my tokens funds and staking

make sure your address is the same as you had before. otherwise maybe you needed to import as legacy wallet