Wallet (desktop Windows) Add network does not save decimal settings

Added a new Wallet network, the decimal setting does not seem to save. The balance for the default token on the network is displayed with 0 decimal places. If you edit the network it shows “Enter currency decimals” with no value.

Same failure on 2 Windows machines. The android version works OK.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Can you specify which network you tried to add? Did you use the “Search network” functionality in brave://settings/wallet/networks?

Can’t repro this. Would be good to see the exact decimal values you are trying to add

Sorry, I should have clarified this was for a private instance of Geth. I was using the default 18 decimal points for ETH, although I have tried every number from 1 to 20. I am unsure if any other non default networks behave the same way as it seems like brave add network has a comprehensive list of blockchains.

The windows version I can enter any value for decimal places in the network and it will not hold. It displays as if there were no decimal places and when you edit the network settings it is back to “Enter Currency Decimals” as if it didn’t hold the decimal number entered.

The android version of brave works correctly.

This is sure to be a little encountered bug as private blockchains are rather rare outside of testing.

Yes, I have the same problem and it is utterly frustrating and unusable for development.
The decimal entry doesn’t stay and if you go back to edit it is empty…simple geth/clique POA setup.

Also it doesn’t take regular auth on RPC endpoints making private blockchains like kaleido or your own setup not usable…

These not so little bugs might be rare for regular end users, I agree, but this is not rare for someone developing a dapp at all.