Wallet connection issue


I cannot connect my wallet to any site. Both metamask and brave wallet. Tried cleaning all cache, cokkies etc. Nothing works. In firefox everything is fine but I don’t want to change browser. Is this something related to latest updates ?

I attached screenshot from one website. All the other don’t even give any signs. No pop up, no error, nothing.

Version 1.39.122 Chromium: 102.0.5005.115 (Official Build) (arm64)



Same problem here! Help please

I fixed it, go to brave://settings/wallet and select “None” in Default cryptocurrency wallet, and restart the browser (and close those sites wich you can’t connect)

1 Like

Strange solution but great if it works. For me it doesn’t. Still the same. Restarted browser, extension, closed all sites, cleared cache and cookies. Nothing works.

Posting Help Center topics with information that may help.

Quoted section per defaults below.

Default cryptocurrency wallet - Use this option to set the default wallet the browser will use when interacting with dApps while browsing:

  • Brave Wallet (Prefer extensions) - Select this option if you have a Brave Wallet created, but want sites to default to using a different wallet extension, such as MetaMask for dApps.

  • Brave Wallet - Select this option if you want dApps to use your created Brave Wallet.

  • Crypto Wallets (deprecated) - Select this option if you elected to use the old Crypto wallets setup rather than the new Brave Wallet implementation. Depending on your installation, you may not see this option.

  • None - Select this option if you do not want sites/dApps to interact with any installed or created wallets.

1 Like

Unfortunately none of this works. I will wait for an update. I hated to do that but I already migrated to Firefox. Hope to see the solution one day.

Seriously it still does not work. I really like brave and I fell uncomfortable using the fox. Are there any updates on the horizon? Is it some known issue?

Here is a topic that may apply: Brave wallet defi connect
Quotes from topic:

Also, have you tried with metamask extension disabled and other setting options at brave://settings/wallet to see if anything changes?

If you tried those steps, you may want to try these additional troubleshooting steps:

  1. Make sure your Brave and OS versions are updated. Brave version is currently 1.40.107.
  2. What is your macOS version? (found at brave://version)
  3. Try these scenarios and see if the problem still occurs.

@brian @Mattches Moving topic to Brave Wallet (Self Custody) category and tagging support staff.

1 Like

Hey @piatas,

This is happening for every site? If not, it might be a compatibility issue, could you provide the site you are trying to connect to?

Noticed you are on 1.39.122 our latest version is 1.40.107 Chromium: 103.0.5060.53 (Official Build)

These steps may be helpful! :slight_smile:

  1. Go to brave://settings/help and update to the latest version
  2. Then go to brave://settings/wallet, click on Default cryptocurrency wallet and make sure it’s set to Brave Wallet

Then please attempt to connect to your site again and let me know if your still having issues!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.