VPN stopped working after a few months

Description of the issue: been subbed for a while … was working great, but about a week or so ago the VPN won’t load any websites when turned on … i’m using iPadOS 17.1.2 (the latest update) … and using the latest Brave update from the app store … i deleted it and installed it again but its still isn’t working.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):

Additional Information:

@TSF,
Thank you for reaching out.
Does this happen regardless of what region you connect to?

Yes … i tried all of them

@TSF Do a favor.

  1. Are you enabling VPN through Brave’s menu or through your iOS?

  2. While connected, go to Brave’s SettingsBrave Firewall + VPN. First off, does it say Enabled? Second, what does it show for Status and Expires?

  3. If you go to your iOS SettingsGeneralVPN & Device ManagementVPN(i) on the right of Brave Firewall + VPN → turn off the toggle for Connect On Demand

Third option resolved an issue for me that had happened on my iPhone after iOS did an update to 71.1.2. Turning off the Connect on Demand let me get my internet back. Then from there when I activated VPN again, it worked.

Now, I’ll also say part of the issue I had on my iPhone is because it had me in a logged out state. Such as it didn’t recognize I had subscribed to the VPN. So I had to sign in again (I didn’t pay through App Store but had done it on Desktop). This means our situation might be a bit different, but I’m just curious if may resolve.

NOTE
Eventually Connect On Demand will enable again, especially if you change VPN regions. This shouldn’t be happening and is something Brave will need to look into, but at least it’s something to check.

VPN On Demand allows the system to automatically start or stop a VPN connection based on various criteria. For example, you can use VPN On Demand to configure an iPhone to start a VPN connection when it’s on Wi-Fi and stop the connection when it’s on cellular. Or, you can start the VPN connection when an app tries to connect to a specific service that’s only available via VPN.

So if disabling the VPN On Demand resolves for you, it might give feedback that devs have something screwy going on in settings.

cc: @Mattches

1 Like

@Saoiray thanks, came to say the same thing about Connect on demand and whether or not @TSF has it enabled or not. Also updating my iPad right now to test and see if I’m able to use the VPN.

  1. through Braves menu.

  2. yes its enabled when i turn it on … yearly subscription … 01/09/2024

  3. the Connect on Demand is ‘off’

Going to reach out to some team members who might know more — just to ensure I understand the behavior here,

  • you are able to connect to the VPN successfully, but when you do websites don’t load.
  • You have had the VPN for quite some time now — purchased the yearly subscription that expires on Jan. 9th ,2024
  • Connect on demand setting is Off on your iOS device
  • You’re using an iPad (what model?) with the latest software update 17.1.2

All of the above is correct?

1 Like

Thank you guys … iPad pro … yes/correct to the rest of the info above … thanx again

@TSF,
Have you tried resetting your config yet ( Settings --> VPN --> Brave Firewall VPN —> Reset Configuration)?

just tried it … it didn’t work

@TSF,
Thanks for the information.
Can you now please try going to the iOS VPN settings and deleting any/all Brave VPN profiles, then going back to Brave --> Brave VPN and reinstalling the profile and see if this helps?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.