Vimeo videos no longer loading, even with shields down

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting


Description of the issue:
How can this issue be reproduced?

  1. Embedded vimeo videos are no longer playing
  2. On multiple closed community sites, wherever there is an embedded vimeo video I see this message in the video box instead: “Sorry
    Because of its privacy settings, this video cannot be played here.”
  3. I’ve tried turning shields off for the sites and it still doesn’t load

Expected result: video should appear with a play button

Brave Version( check About Brave): v1.45.123

Additional Information: This issue just started in the last few days. I assume since the last update.

1 Like

I just noticed this appears to also be a chrome issue. However everything loads fine on Safari.

I’m having the same issue loading Vimeo videos; however, they play fine in Chrome.

Hello there @lon Could you please try opening your main profile in private or guest mode to see if the videos load? If they do load, try disabling your extensions to see if this is the cause of the issue.

You can open a Guest Window by going to Main menu --> Open Guest window:

  1. On your computer, open Brave.
  2. At the top right, click Menu → More tools → Extensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.
Regards.

Thanks for the response on this. Solved the extension was Bitdefender Anti-tracker.

Thought I’m not sure why a tracking blocker would cause so many video issues.

1 Like

Hi there @lon thanks for confirming that the issue was solved. If you still are experiencing issues with the extension, ,you can report to the extension’s developer you had the issue and they might be able to make modifications.

If you have any other concerns, please let me know.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.