Viewing PDF files at FTP addresses in Brave browser

Description of the issue:
I am unable to view PDF files located at FTP addresses in the Brave browser. Instead the download and save prompt pops up, with no option to simply open the file.
Usually this is no problem, but since I am currently switching between many PDF documents, it causes a lot of hassle, because I need to know where I have saved which files and then I also need to delete the ones I don’t need anymore.

Is there a simple, secure way to open PDF files at FTP web addresses in the browser?
Failing that, is there some way to save downloaded PDF files to a temporary folder that is removed/emptied when I close Brave, per default?

How can this issue be reproduced?

  1. Find any PDF stored at a FTP address, e.g. almost any one linked on this page:
  2. Follow the link

Expected result:
PDF opens in browser like most PDF files located at HTTP(S) addresses.

Brave Version( check About Brave):
Windows 8.1 64-bit
Version 1.2.41 Chromium: 79.0.3945.88 (Official Build) (64-bit)

Additional Information:
I have the site setting for downloading PDF files instead of opening them turned off.
The problem persists when I have deactivated all my extension.

Thanks for reaching out to us. So I’m really not sure what the issue is – on my end, I visited the site you provided and was able to view the PDF file in-browser without issue:

Can you tell me if you have any extensions installed in the browser?

1 Like


I have the following extensions installed:

  • DuckDuckGo Privacy Essentials (not allowed in private windows, and no access to URLs)
  • uBlock Origin (allowed in private windows, but no access to URLs)
  • uBlock Origin Extra (allowed in private windows)

But the problem persists when I deactivate all of these.

Edit: I just checked that the link you show having tried (CRIRES cookbook), is one of the (few) ones that is not at a FTP address but a HTTPS one. Could you try another? This one, for instance:

So it looks like I’m seeing the same behavior in Chrome and FF – I believe this is the intended behavior for these particular files.

Can you try using a different browser and try to view a PDF file as you were in Brave? You should get the same behavior – which would imply that this is site dependent, rather than something the browser controls.

1 Like

@Mattches You are correct. I get the same behaviour for these files with Firefox, and I can open some FTP files from other sites in Brave.

I guess my next question, would be: Is there a way to override the website forcing me to save rather than open downloads?
If not, does Brave possess a temporary folder similar to Firefox, which automatically gets emptied after each session? ('Cause then I’ll just save downloads there…)


I do not believe there is a way (at this time) to override the site’s setting for this. Brave does not have a specific download folder – however, you can set up your own folder in which Brave downloads to, which you will allow you to collate any/all downloads in one place and delete them (if thats what you’d want to do).

Apologies for the inconvenience.

1 Like

Not at all. :slightly_smiling_face: Thanks for taking the time to look into this!

Edit: Feel free to close this topic

1 Like