Viewing Newsletter Web-Versions


#1

Not sure why, but the web-version of this ello newsletter won’t display in Brave, but will display in Chrome…
… [ see link ] @ http://us3.campaign-archive2.com/?u=9ad48e023e0e67d4a8cda3fc9&id=536d94a611&e=bd935b72b0

I’m fine with tweaking Brave to allow this content to display, but it did force me to Chrome today… which was not cool.


#2

The problem is that the site loads the images from http and the shields block them for security reasons :wink::hugs: You can temporarily fix it by disabling https everywhere :lion::wink:


#3

You are the master of this, cc @luke.mulks


#4

Hey everyone,

Will investigate and follow up.


#5

I tried disabling HTTPS, and the newsletter still is not displaying remote-content in Brave, [ see image ]


#6

It worked for me on iOS to disable https :grimacing: I had the same problem :wink:


#7

@sinja @Jacalz this is an interesting one.

I have started taking a closer look, and have tested some workarounds while I investigate further.

Right now, the only shield setting preventing this newsletter from displaying is the ad blocking shield.

I have tested with cookie controls off/on, https off/on, and with ad blocking on and off. It turns out that ad blocking is the switch that prevents this from rendering.

Disabling the ad blocking setting should resolve short term.

I took a closer look at the source code, and it looks like Ello is treating the content as if it was an ad for it to work with the mailchimp newsletter system. I need to see a little more as to why, but that is what I am able to see so far.

I am going to check against other blockers to see if we can set an exception filter to allow for this to work without manually adjusting in the long term. Will open an issue and update with a link here for tracking progress.

Stay tuned


#8

I am now seeing the remote-content if and only if Shields is toggled to [ Down ] … [ see image ]


#9

Ah I see, yes, if I switch [ Ad Control ] Drop-Down to [ Allow ads and tracking ] then it instantly loads the content. So then… it was working with the entire shield down because it also disabled ad control.

Thanks ! Back to Brave!


#10

No problem, happy to help! :slight_smile:

Will look into the long term fix to make it so you don’t need to turn off ad blocking too, and will update here once I finish that up this week.

Thanks for testing this out too @Jacalz!


#11

I guess it is a bit confusing … You can see that even with Ad-Blockers up in Chrome… it’s loading the content… [ see image ] …

So in this case, Brave looks like it’s treating prime image content as ads which causes UX to fluctuate a bit drastically by needing to toggle a Drop-Down to get content to load that isn’t really an ad…

But it seems the way Newsletters are delivered is making Brave think they are ad-content, interesting.

I wonder if Newsletters are strict enough to catch this once and for all(?), or, if it’s a consistent thing per-Newsletter that Brave will need to adjust to?

Either way, I’m glad I can access the content in it’s entirety within Brave… even if I do need to toggle a setting here and there. Perhaps, you can connect some keystrokes to ad-controls, so that my access is behind say… a Cmd+L for (L)et-Ads-display… Just an idea… I’m sure they’re more efficient ways to manage this confusion.

Enjoy your day and thanks again for Brave !


#12

Oh now I see that it is ad block making it not load strange must have done something stupid when I got it to be https related :grimacing: It doesn’t really matter but it is clearly strange to set the newsletter to look like an ad :hugs: Good luck @luke.mulks


#13

Another Newsletter with similar behavior based on allowing ads and trackers is at the following link: http://mailchi.mp/c52e313a7f37/culture-as-competitive-advantage?e=cc12914697


#14

Thanks @sinja!

I am going to open an issue for both of these, and will follow up with a link for tracking progress.


#15

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.