Videos don't play with "shields" tracking and advertising blocker on


Today i installed brave and with the 1st site i opened i could not play the videos in this site.
This is the site:
Scroll down to the bottom, and there you will see a bunch of videos.

Interesting is that when i visit the same site with brave tor it works like it should :slight_smile:

After some disabling and testing i found out that the above mentioned tracking and advertising blocker caused this.
Of course i would like to keep this feature enabled. Is this perhaps a bug?

Is there perhaps a workaround, so that i can still have this feature enabled?

I use the most recent version of brave, updated after installation.

V1.28.105 (Aug 11, 2021)

For information, I can confirm.
Methinks you should click that “report broken site” on the shields window.
Two of the blocked trackers are and from that same site, my bets are on those.
Some sites employ anti-ad-blocker techniques, not sure if this is the case or simply their bug.

update: see Can't switch between accounts in YouTube - #9 by fanboynz for a similar problem and temporary workaround – meanwhile I read up on adblock syntax.

Not quite the same syntax. No issues playing (video at the bottom)

Strange. Even that video doesn’t play here without allowing trackers and ads.
But @@||^ in brave://adblock seems to work (too generic, I know).
@@||^ also works. Thing is, it will load other scripts after those ones and I’m still trying to narrow the filter.
Re syntax, is compatible with AdBlock Plus, right?

Correct, was reffering to the cosmetic exceptions wouldn’t work here.

@@||$script, in brave://adblock is needed, since blocking this script will cause playback issues

1 Like

Hell, that filter doesn’t work for me (or I’m going to slap myself very soon, I’m not sure).
I did refresh the page though.

Does it work in private window mode, with no extensions enabled?

No, doesn’t work even in private window. Nor does @@||^.
I’m quite sure there are no extensions involved because I never installed one.
I wanted to “clear browsing data” but the menu item is disabled in the private window, I guess because there’s nothing to clear.

I’ll recheck later, maybe try a vpn from a different location? (non-eu)

I tried with a “private window with TOR” and it worked.
It worked even without the filter exception though (with TOR).
I’d say that site is employing some trickery.

At first i used the global “allow trackers and advertisements”, but i did set this back to default, and now i use the “allow all trackers and advertisements” setting next to the address bar.

@ fanboynz: i am using vpn from non-eu location.

@ elder-n00b: yes i had this too. private window with tor worked as it should, which i think is kind of interesting.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.