Video not working on Android

Description of the issue:
When I log into a website that has videos they do not play they just give me a squared sad face. This happens with or without the shields on. This only happens on mobile. It works fine on my computer.

How can this issue be reproduced?

  1. Login to the website and try to watch the video.

Expected result:
Watch the videos within this website.

Brave Version( check About Brave):

Mobile Device details
LG G8 thinq

Additional Information:

Is this specific to that site? Does it work on Chrome?

Yes. Yes it does work on chrome

here is chrome

What page is this on? Can you share a sample link where its failing to play videos?

I wish I could. It’s a membership site. I did learn that the videos are played though Vimeo. If that helps.


I also have the same problem in my Huawei P10 Lite.

I cannot see Vimeo videos in a site where I study japanese online: (sorry, it is necessary a membership to access the site).

I also see a sad face in the player space, with Brave Shields ON or OFF. I tested in other browser (Via Browser), it is OK. In Brave for Windows, it is OK.

I tried to change some settings and flags in Brave for Android, but the result was the same, a sad face.

What can we do?

Thank you!


Could you check by disabling Shields(Lion icon in URL) and check if it works? If so try enabling shields and disable block 3rd party cookies and check if that fixes the issue?

Tried all those ways. Still no fix.

Thanks for the updates. We will need some time to investigate the issue. Keeping the thread open for now

please check above link… videos are played though Vimeo …not working.

thank you

1 Like

Hello Guys…is this bug going to fix in new update ? Please reply…

Hi please check this link

login as guest user…vimeo link won’t work in mobile…

thank you

There is an open issue for this

Could you guys try the new Brave Beta that is available via Play store and see if it works there?

I have tried the beta version and it does work. Great job!!!

Fwiw I was having the same problem after the update, downloaded the beta, and the problem is fixed! Great! Now I’ll wait for an update so I don’t have to migrate all my bookmarks and settings…: )
Nice work, and fast, too!

Ok great to hear that issue is fixed on beta. Going to close the thread for now based on the feedback. Any issue on the current release do try it on beta as well as we’ll be moving to the new code base. Any issue on beta do open a new thread so that we can fix that up as soon as possible