Video Card Crashes when using Brave

Video card crashes after anywhere between a few minutes and a few hours of starting Brave.
Yes, I have latest drivers.
This has been happening for a few months. I wasn’t sure why, but I kept on eliminating causes and it seems that Brave is causing it (Have been using Chrome for a few days now with no issues)

So basically, if I use Chrome or any other combination of apps on my computer, everything runs fine (though depending on how many, it’s sometimes a bit slow). But when I use Brave, after random amounts of time, my screen will go blank. Sometimes after a few seconds, the screen comes back after a few seconds and I get a windows error letting me know that my graphics card crashed. But usually, the screen stays blank. The computer still seems to be functioning, but I can’t see anything because the video card is not doing anything. The only way to get anything back is by rebooting and since I can’t see the screen, I usually do a hard-reboot.
I actually love Brave in general, but I can’t use it like this at all. So I’d love it if anyone can help here. Thanks.

Version 1.8.90 Chromium: 81.0.4044.129 (Official Build) (64-bit)

Running Windows 7 x64

If you’re able to get to the brave://settings/system page, disable hardware acceleration and try again.

Ultimately, the bigger issue is that Windows 7 is not officially supported by Brave. :frowning: You still may be able to get it to run, but it’s likely that much of the functionality will be broken, and in such cases we can’t offer advice or troubleshooting beyond “upgrade to Windows 10”. Sorry for the inconvenience!

1 Like

Also depending on the graphics card, some systems do have buggy graphics drivers (Intel and to lesser degree AMD graphics drivers can cause issues if hardware acceleration is enabled).

1 Like

if your are not able to start brave to change the settings without crashing it try this:

  1. Launch Brave by shortcut with --disable-gpu flag
  2. Go to Menu --> Settings --> Advanced --> System --> Hardware Acceleration
  3. The option should be off – switch it on, do not relaunch when prompted.
  4. Return to the shortcut you used in step 1 and remove the --disable-gpu flag
  5. Now go back to the Hardware Acceleration setting and toggle it off
  6. Relaunch the browser when prompted.
1 Like

Thank you! That seems to work. I actually had no idea that Win7 wasn’t supported, but thank you so much for giving me the answer anyway. I love Brave (and have been using it on mobile since LinkBubble), so I’m glad this worked for me. So far so good.

Also thank you @fanboynz and @m4rc3llo for the help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.