Verification loop when trying to re-connect Uphold wallet to Brave

When I hit the Brave Rewards button, I am told that my Uphold wallet was disconnected. I click the gray, oblong Disconnected button and am brought to a login page. I enter my uphold credentials and Authy 2FA code, then I am brought to a page that requests that I verify the device for uphold. I click the link in the email, and it brings me to my main Uphold page, logged in. When I go back to try to reconnect the wallet, it demands a new email verification and this process never completes. I can sign into Uphold just fine, but Brave refuses to do my apparently-necessary 90-day reconfirmation.

Running shields-down doesn’t help. I’ve been getting hit with these ads everywhere but can’t even get my payment for them (even though it has worked just fine in the past).

I solved this one on my own. When signed in to Uphold send an offline message to their support team via chat. You will receive an email to allow Zendesk. Authorize Zendesk with shields down, then go directly back to Brave rewards and hit the Reconnect button again. This somehow triggered Uphold to know that I was already logged-in on this device and allowed the Reconnect to occur. Hopefully this helps someone else - I discovered it inadvertently when I decided to try it once more after the authorization worked just fine for Zendesk after sending a support ticket to Uphold.

2 Likes