USPS Informed Delivery won't load

USPS Informed Delivery not working on Brave browser. Works on other mobile browsers. I click “login” and page ultimately times out to “service not available”. Samsung Galaxy S10+. Latest version of Android and Brave. Brave shields are down.


Thanks for bringing this to our attention and sorry to hear you’re having trouble with Brave. Could you kindly update to the latest Brave version.

Let me know if that fixed the issue and have a nice day!

Hi Alice. Unfortunately it still does not work. I updated to the latest version of Brave, went to apps, cleared cache for Brave, force stopped Brave, restarted my device, and tried to login to USPS informed delivery. Same issue. Page either times out or gives “this service currently unavailable, go to” message.

Tried it on Chrome and Samsung Internet. Worked on both of those browsers.

Using a VPN? Loading works here

No VPN. That website loads for me but when I click on informed delivery it won’t load and eventually times out. Only happens on Brave. I’m stumped.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.