Use custom Search Engine as default in Address Bar / Omnibox search

Description of the issue:

Hi - so I’m trying to get my default Search Engine to do searches with Google, but specifically, Google South Africa. So, google.co.za.

So, I can add a custom Search Engine in chrome://settings/searchEngines, but when I go back to chrome://settings/search I cannot select that custom search engine as the default for the address bar.

Any pointers?

1 Like

Let me know if this article not “solve” your issue, @jasunx https://support.brave.com/hc/en-us/articles/360017479752-How-do-I-set-my-default-search-engine-

1 Like

Hi eljuno,

thanks for the reply.

Okay so here’s something I did not do, which the article doesn’t specify either.

  1. I have to go to Settings, and click on Search engine in the left column.

  2. Under Search engine I must click Manage search engines.

  3. Here I can add my custom search engine beneath Other search engines.

  4. Here’s the step that I didn’t do: After adding my custom search engine, I must click on the 3 DOTS to the right of the custom search engine, and choose “Make default” from the list.

  5. This now ads it to the Default search engines list. This also automatically makes it the default for the address bar.

  6. Now, back in Settings >> Search engine - I will find my custom as the default for the address bar. I can also click on it and find the others in the drop-down should I wish to change it.

I would suggest either adding this to the article, or changing the option inside “Manage” to "Add to Default list.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.