URL bar unresponsive on first 2-3 characters when having "show history matches" on


#1

The versions

Brave: 0.23.31
V8: 6.7.288.46
rev: 3148acef36dba0fce89108638bb27927c4937f90
Muon: 7.1.5
OS Release: 10.0.17134
Update Channel: Release
OS Architecture: x64
OS Platform: Microsoft Windows (also occurs on OSX)
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 67.0.3396.103

Steps to reproduce:

  • Enable “show history matches” in search bar options.
  • Have quite a few items in your history (I imported my history from chrome and that’s at least half a year of browse history).
  • Type in the URL bar

What happens:

  • When having only 2-3 characters in the URL bar there is a 3-5-second lag between typing and the character being displayed.
  • Once you have more than 3 characters response is instantaneous.
  • If you delete all characters but one and then type another one that you didn’t type before, it’s slow again until you have 3 or more characters in the line.
  • If you disable “show history matches” typing is without delay as well, so it must be caused by the history search feature.

An educated guess as to why that happens would be that when you only have 1 or 2 characters in your search this yields a lot of results which Brave needs to chew through when sorting the results by relevance or whatever is used to sort the results. Once you type more characters the number of results probably gets down very fast, hence it’s no longer sluggish. It could be fixed by either only starting a search once you have a reasonable amount of characters (e.g. 5 or so), or by ignoring anything that is more than 10 or 20 results when sorting the results for display.


#2

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.