Uploading any file causes Brave to freeze

Description of the issue:

When uploading any file, Brave freezes completely freezes, and nothing is accessible. It’s not possible to visit an other tabs, and the menus aren’t accessible either. To be able to reuse Brave, I have to kill it using the command line and reopen.

How can this issue be reproduced?

On Facebook:

  1. Open Brave
  2. Log into facebook.com
  3. Click on ‘What’s on your mind’ to create a new post
  4. Click on Photo/Video
  5. Click on ‘add photos or videos’
  6. Select a video or photo
  7. Click open (this causes Brave to freeze)

On Easy Upload:

  1. Open Brave
  2. Go to https://easyupload.io/
  3. Click on ‘click here or drop files to upload’
  4. Select file to upload
  5. Click open (this causes Brave to freeze)

Expected result:

File should be uploaded, web page can be browsed and other tabs should be accessible as normal.

Brave Version:

Version 1.47.186 Chromium: 109.0.5414.119 (Official Build) (64-bit)
Ubuntu 22.04
Apt source: https://brave-browser-apt-release.s3.brave.com/ stable main
(i.e. Not the snap package)
All the included packages are the default packages for Ubuntu - no customisation of the libraries has been done.

Additional Information:

This is not the only time that Brave has completely frozen, though I didn’t notice exactly what cased the other freezes. I’ll update this report if I work it out.

Hello @eugaia

could you disable all extension or try in private mode

if it work fine then either you have issue with one of the extensions or you need to clear your cache/history

hope that help and have a nice day :slight_smile:

Thanks for your reply @justsomeone1. I tried both of:

  • Using in private mode
  • Disabling all extensions

Both resulted in the same issue, i.e. Brave still froze with both situations.

you welcome @eugaia

could you try to create new profile from the menu choose create a new profile

and see if it work fine there or not

could you also try while shield is down

Hello @eugaia

Thank you for reaching out and I’m sorry to hear you are going through this. As @justsomeone1 mentioned, please try to create a new profile. To create a new browser profile (Menu --> Create new profile )

Let us know if that helps!

1 Like

@justsomeone1 @Alice2095 I tried creating a new profile and turning off shields, and Brave still freezes and needs to be stopped using the command line.

Hello @eugaia

did you change any of the flags here brave://flags/?

if you did then reset them back to their default

Hi again! @eugaia

Thanks for your reply we appreciate the details. please try in Private mode or Guest Window to see if the behavior persist. If that works, try disabling your extensions to see if this is the cause of the issue.

  1. On your computer, open Brave.
  2. At the top right, click MenuMore toolsExtensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let us know if that helps!

Hello @eugaia, might be something related to the graphics I have seen similar issues while uploading/saving pictures or files, we can make some test, try disabling Hardware Acceleration** – disable it and see if performance improves (Settings --> Advanced --> System --> Hardware Acceleration) Hope this helps. Regards.

@justsomeone1 No, no flags were changed.

@Alice2095 I’ve tried in private mode, with a second account, with no extensions installed. The problem persists.

@Jarc-1107 With hardware acceleration disabled, with a second (clean) profile, no extensions, private browser - still freezes on uploads.

i can think of 2 cases

  1. create new user account (linux user account not brave profile) and see if it help or not

  2. could you install chrome or any chromium based browser as maybe it something related to the chrome part

@justsomeone1 So I’ve tried the following:

1 - Created a new test Linux user
2 - Tried Brave (apt), Brave (snap) and Chromium (snap) under both my main and new test user

Chromium - Version 109.0.5414.119 (Official Build) snap (64-bit)

For my current user account, all the three froze on uploads.
For the newly-created test account, the apt version of Brave froze, but the snap and Chromium versions didn’t freeze.

At a push, I could just use a new account and remove my current one, but I was really wanting to eliminate snap altogether. Also, I’d rather this issue were isolated and resolved, so it no longer becomes an issue.

I’ll try doing a fresh install of Ubuntu to see if the issue exists with fresh installs. Will report back when I’ve done that.

Hello @eugaia

despite i am just a user same as you but to be honest this the first time i see someone said that snap version of an app work while apt fail

you can simply try to boot using the live cd of ubuntu and install brave there and see if it work or not to same the time for installation

@justsomeone1 Yes, good idea. That’s exactly what I did.

When I ran a fresh version of Ubuntu 22.04, and installed Brave using apt, everything was fine. I also tried the snap version, and that was fine too.

I guess my solution will be to reinstall my OS. :frowning:

Thanks for your help, guys.

sorry to hear that you need to reinstall your os but if you still did not then not sure if read the log of your os would help you or not

try to find how to read logs of the os in ubuntu

and you welcome and have a nice day :slight_smile:

Hi again! @eugaia

I wanted to know if the issue was solved?


Hi again @Alice2095. Thanks for checking up on this.

After reinstalling Linux, Brave went back to working properly. I’ve no idea what the cause was, but I’m good now.

Thanks again.

1 Like