Upload button doesn't work on any site

I have seen other topics on this but they are all closed without a resolution, so starting a new one.

Any upload button, on any site, simply does nothing. It’s supposed to open the finder window so you can select a document, but nothing happens.

I have obviously verified the sites all work in regular chrome.

I tried with shields off. I tried without any chrome extensions enabled. There are no console errors.

Im on Mac (Monterey 12.16.1) and Brave(desktop) Version 1.46.144 Chromium: 108.0.5359.128

I don’t want to go back to Chrome but if I can’t resolve this, I’ll have to :slightly_frowning_face:

Tried with New Profile and/or Private Window?

Also, someone had a similar issue earlier this year on Chrome. The solution was:

System Preferences > Security & Privacy > Privacy Tab > Full Disk Access > Press the lock symbol to unlock [bottom right of window]> Select Chrome and add it. > Now restart Chrome.

Can you try that? Obviously you’ll be doing for Brave instead of Chrome, lol.

That did the trick! Thanks so much, such a simple solution!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.