UPDATED : Few Tips for Those Who is Not Receiving ADs

I would like to give some tips which I have experimented on my Smartphones and PCs and all of them working fine for me.

First Check These Common Things

  • Make sure you have your maximum number of ads set to maximum (5 ads per hour)

  • Notification is on for your Brave Browser App. (To check go to Browser Settings > Notifications > Enable Show notification)

  • DND (Do not disturb) mode is off.

  • Check active campaigns here > https://brave.com/transparency/

Here are my tips which I have experimented

1. Turn Ads option Off and On. (For PC try turning off Rewards option too.)

2. Try turning airplane mode On and Off.

3. Restart your device.

4. Make sure you have more than 3 tabs open in your browser.

5. Keep the app in the background (Lock it if you have that option).

  • To prevent the system from killing the app make sure Autostart is enabled and Battery Optimization is disabled for Brave Browser.

6. Make sure you have “Show Ads when Brave is not in use” option is enabled. (Settings > under Privacy section - Brave Rewards > First option.)

7. You can keep Brave Browser in the foreground when leaving the phone alone or in charging.

8. Make sure to open a browser for at least 3 times a day so that the Browser will take you as an active user, also refresh all those tabs.

  • If you do not receive ads for one day or two then it’s fine, usually happens with me too. Sometimes it increases up to 3 days so always be patient.

  • I have experimented on VIVO S1 Pro, Samsung Galaxy Note 8, ASUS TUF GAMING (Laptop), ASUS Vivobook S15 (Laptop), Xiaomi Note 5 Pro, Google Pixel, Xiaomi Mi Max/Prime, VIVO V7 Plus, Samsung Galaxy S9, VIVO V5 Plus, Lenovo C200 (Computer), Galaxy S4, Galaxy J7, Xiaomi K20/Pro, RedMagic 3, OnePlus 3.

(I have not tested it on any iOS device, any one of you does then please give us feedback.)

  • One more thing I do not spend hours on Brave Browser still I receive ads and I’m from India.

Risky method :-

This method will 90% work and many people using it so thought to add it here.

Use VPN (Android and iOS)

Connect to United States - New York or any other states.

Once connected to VPN, exit from your browser and reopen it and use it for few minutes you should start seeing ads.

Before using this method please visit this thread if is there any statement by admins saying this method is illigal then do not use it!

That thread :- Creators Account will get suspended If I tip my self?


Temporary solution for Windows users :-

Thanks to @Rotblut for Windows method.


Proofs

Brave Ads PC Proof

More proofs will be added once I receive them from my friends and relatives.

In Rare Cases :
  • Any of the tips that I have given may cause pending rewards stuck. (don’t worry it will fix itself.)
  • It may reset your ads count to 0 which is totally fine.
Disclaimer

Those all steps are self-experimented and seem working fine for me, it may not work for you.

I have not encountered any issue turning ads on and off, if you do then it is not my fault.

Any of the above-mentioned steps doesn’t cause estimated pending rewards to decrease neither any type of display error on Rewards Panel nor any type of decrease on Ads value.

Ads also depend on the region, country, and active ad campaigns.

Also Check

No ads since I installed

FAQ: Why am I not seeing Brave Ads?

Brave Ads Windows 10 Troubleshooting

Hope it helps, if you have any more tips then feel free to share.

51 Likes

The ads turning on and off works for me but I have to do it often to make it stay work.

Dude I didn’t knew about “Show ass when brave is not use” lol

Thank you so much for the tips man :+1:t2::+1:t2:

11 Likes

Thanks for sharing, will try these and give feedback

2 Likes

Just notice inside the ads setting got a new function. State level of targeting. You set to auto-detect? Anyone notice that function?

In which version? Official, beta or nightly?

Official… I am using mac. Window also got I think.

Oh where exactly that option is located?

U go to brave reward > Ads > Ads setting > there will be second column State level ads targeting.

Below “Maximum number of ads displayed” option?

I didn’t see any other option there.

Neither in the Ads panel!

Could you share a screenshot?

Oh that’s something new! I don’t have that option.

Version :- 1.12.112 Chromium: 84.0.4147.125 (Official Build) (64-bit)

Thanks for sharing.

I’m using latest version, but i don’t have that option

@Irfandeva I checked my other desktop pc window don’t have. I’m not sure that function also. I jz set to auto-detect.

i do not have this one also i am on linux

Looks like the staff team is aware of this issue, requesting lock @eljuno.

7 Likes