Updated 1.34.80 private mode GTK+ theme reverts to purple

With the updated version 1.34.80 the private mode theme has reverted to purple. Prior to this update, the GTK+ theme would reflect the OS colour scheme rather than the ridiculous purple.

How to reproduce

  1. Update to 1.34.80 on Linux Mint 20.2 (Mint-Y-Gray theme)
  2. Change Brave > Settings > Appearance > Theme to GTK+ (Previously this would change the private window colour scheme to gray)
  3. Launch private window
  4. Close your eyes to prevent headaches from ridiculous purple colours

Brave Version: 1.34.80

Additional Information: On Windows 10 with previous versions the purple could be changed by adding a Chrome theme but I’ve tried this on Linux also but it still won’t change the colour theme of private windows.

(I know some people advocate that private windows should be a different colour to make them easily identifiable but I use only private windows so I really don’t need this. I simply cannot work with this horrendous purple.)

Hi, you can gain the ability to apply your Theme to Private Window by Disabling a Flag named “Enable Incognito brand consistency in desktop” through brave://flags.
Hope that helps

1 Like

Excellent, thank you - that worked.