Update failed (error: 11)

Description of the issue: Right after installing Brave updates and relaunching it, the internet doesn’t work and it is needed to restart the computer for it to work.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Click the green update icon when an update is available
  2. Wait for it to update and click Relaunch

Actual Result (gifs and screenshots are welcome!):
Internet does not work, any site does not open. When looking into the About Brave tab, this error is shown:

Update failed (error: 11)

Error details:

An error occurred in retrieving update information. Please try again later.

Learn more

Version 0.69.135 Chromium: 77.0.3865.120 (Official Build) (64-bit)

Expected result:
You should be able to navigate

Reproduces how often:
Every time I update Brave

Operating System and Brave Version(See the About Brave page in the main menu):
MacOS Mojave version 10.14.6
Brave Version 0.69.135 Chromium: 77.0.3865.120 (Official Build) (64-bit)

Additional Information:

@gabrielmulle,
You don’t need to update – version 0.69.135 is the most up to date version of the stable browser at this time.

Hi @Mattches, yes, I’m aware I’m already in the lastest version, the problem is not that. The problem is: I am not able to navigate right after an update and that error message is shown in the About brave page.

@gabrielmulle,
Can you tell me if you’re using any extensions in the browser at this time? Additionally, do you have any anti-virus software installed on you machine?

1 Like

@Mattches, yes, see below:

Extensions

  • LastPass
  • FVD Synchronizer
  • New tab clock
  • SmoothScroll
  • Simplify Gmail

Antivirus

  • Kaspersky (11.0.0.501)

@gabrielmulle,
Can check Kaspersky and see if it’s flagging Brave or the Brave updater as malicious?

Thanks for the update @Mattches. My Kaspersky is managed by my company so I’m not sure if or how I can do that. But I’d guess it is not flagging it as malicious otherwise I think other stuff would stop working. I think we can mark this as resolved, if there is nothing else we can do.

@gabrielmulle,

:point_up: This in itself may be the issue. If your company has custom security setup on the network, it may be blocking Brave from fetching the appropriate update files. Have you mentioned this to your works IT department?

Agree. I’ll let them know, thanks for the help.

Update 28/10/2019
Today the same problem happened with Chrome, so really probably something with my network configuration. I’ve communicated with the team.

1 Like