Update error for Brave Tor Client Updater on Linux (Ubuntu 20.04)

Hi,
When I open a “new private window with Tor” within Brave, I get a Disconnected message. When I go to brave://components/ here’s what I see:

Brave Tor Client Updater (Linux) - Version: 0.0.0.0
Status - Update error
Check for update

So the updates are obviously failing. Does anyone know the URL used for the updates? Perhaps they’re being blocked (I do have OpenDNS blocking some sites).
I’m using Ubuntu 20.04 and Brave Version 1.38.111 Chromium: 101.0.4951.54 (Official Build) (64-bit)
UPDATE: Actually, there is one more thing: I see that brave://components/ is reporting many update errors (even though other components have relatively recent versions installed - i.e., not 0.0.0.0).

hello @dlanced

try to go to brave://settings/extensions and disable tor then enable i again then open a tor window

Thanks. I tried that (including shutting Brave down in between disabling and enabling Tor), but it didn’t help.

you welcome i just check the tor version here it say Brave Tor Client Updater (Linux) - Version: 1.0.25

do you remmber how did you installed brave at first by snap or command line as here

I’m not 100% sure, but I see it doesn’t show up in

snap list

and it does come up for

apt show brave-browser

so I assume I did it using APT

could you try to disable all extension (i mean the one you install not the tor)and try again

and could you try to disable opendns or any vpn in case they block tor or something

There are no extensions that I’ve added. I’ll try to disable OpenDNS a bit later - I’ve had loads of trouble with messing with the OpenDNS config in the past.
Thanks,

There are, by the way, now no update errors left in brave://components/ except for the Tor Client Updater.

@dlanced ,

Suggestions re New Private Window with Tor

Enable the upgrade of navigation to always use HTTPS:

Screen Shot 2022-05-09 at 1.53.50 AM

Disable “Use Secure DNS”:

Screen Shot 2022-05-09 at 1.53.02 AM

(Note: Some say Enable and use one of the Custom providers; but Disable works for my Brave Browser setup.)

Go to: brave://settings/getStarted . . . and set new windows to open about:blank:

Screen Shot 2022-05-09 at 1.55.50 AM

Go to: brave://net-internals/#dns

and click on Clear host cache

Next, go to: brave://net-internals/#sockets

and click on both (in succession):

  • Close idle sockets
  • Flush socket pools

Exit/Quit everything and restart your computer.

Notes re what are:

DNS cache:

Socket pool:

With pooling, instead of closing a connection after it is used, we can keep it idle while it waits to handle another request. This saves the resources required to create a new connection.

Observe: brave://tor-internals/

Locate the cldoidikboihgcjfkhdeidbpclkineef folder and open it:

/home/[username]/.config/BraveSoftware/Brave-Browser/cldoidikboihgcjfkhdeidbpclkineef

Observe the contents of that folder, given the following:

The Tor items therein are supposed to be replaced / updated, when you Disable . . . and wait a moment . . . then Enable the Private window with Tor switch:

Screen Shot 2022-05-09 at 1.45.18 AM

And, within

/home/[username]/.config/BraveSoftware/Brave-Browser/tor

some of the files are created, while some are updated, but I am uncertain about which . . . as a result toggling that switch.

I discovered that, AFTER Enabling the Private window with Tor switch, I had to open a New Private Window with Tor . . . and wait . . . until the Tor component showed up.

Re Component updating, do not block:

  • componentupdater.brave.com
  • go-updater.brave.com
  • variations.brave.com
1 Like

try to disable and enable the tor option again

1 Like

Thanks for all these ideas:

Enable the upgrade of navigation to always use HTTPS:

Done

Disable “Use Secure DNS”:

Done

Go to: brave://settings/getStarted . . . and set new windows to open about:blank:

Done

Exit/Quit everything and restart your computer.

Done

Locate the cldoidikboihgcjfkhdeidbpclkineef folder and open it:

There isn’t any such directory. However, there is one called cffkpbalmllkdoenhmdmpbkajipdjfam

And, within /home/[username]/.config/BraveSoftware/Brave-Browser/tor

There is no tor directory on my system.

Re Component updating, do not block:

  • componentupdater.brave.com
  • go-updater.brave.com
  • variations.brave.com

Done. But after all those tweaks, I’m afraid I still can’t connect using Tor. And brave://tor-internals/ is still just giving me this:

Tor Version:
Tor Process Id: -1
Tor Proxy URI:
Tor Connection Status: Disconnected
Tor Initialization Progress:

@dlanced ,

There are 3 possible folder names for the Tor component:

Also look at

Scroll down to the Updates section, . . . item 17 - notice the test link:

Update to the latest version of the Brave Tor Client Updater component in your browser by triggering an update in brave://components and test that https://brave4u7jddbv7cyviptqjc7jusxh72uik7zt6adtckl5f4nwy2v72qd.onion/index.html loads fine.

1 Like

Ok. The directory name on my system is biahpgbdmdkfgndcmfiipgcebobojjkp/ But couldn’t they have used something just a bit more intuitive like torStuff/ or something like that. :slight_smile:

The directory was empty (not even hidden files) before, during, and after I toggled the Private Window With Tor setting.

I tried (unsuccessfully) to update tor in brave://components/ but was unable to load https://brave4u7jddbv7cyviptqjc7jusxh72uik7zt6adtckl5f4nwy2v72qd.onion/index.html.

So still no luck.
Thanks,

@dlanced ,

Ans: Tor component is not installed.

You might find some indication of that failure, within an installation log file for Brave Browser.

Seek guidance from @Mattches re whom to turn to, for re-installation help.

PS. There is at least one issue at GitHub

Yup. I see I’m getting a lot of references in dpkg files to an incomplete installation:

status half-configured brave-browser:amd64 1.29.76

I should be able to reinstall Brave, although I may just wait until I upgrade to Ubuntu 24.04 in a couple of months.
Thanks,

1 Like