Unsupported command-line flag: --no-sandbox

linux

#23

Any updates on the issue ? Is it safe to use the browser ?


#24

If Brave does not start and shows an error about sandboxing, you may need to enable user namespaces. For security reasons, we do NOT recommend running with the --no-sandbox flag. For more info, see https://github.com/brave/brave-browser/issues/1986#issuecomment-445057361.


#25

This does NOT work on latest brave version (lubuntu 18.10) still the same message every time I open the browser


#26

To reiterate to anyone encountering the --no-sandbox issue on Linux, you need to try and enable user namespaces on your machine. You can find instructions on how to do that here:

You may need to reboot before the changes take effect.

If you do this and it does not resolve the --no-sandbox issue, please let us know in this thread. Please be explicit in what steps you’ve tried to resolve the issue. Thank you.


#27

I’ve tried everything listed on that page. I’m on lubuntu 18.10, no matter what I do the same message keeps popping up at the top when opening brave browser. I tried sudo sysctl kernel.unprivileged_userns_clone=1
echo kernel.unprivileged_userns_clone = 1 | sudo tee /etc/sysctl.d/00-local-userns.conf message still comes up. I’m to the point of just using Firefox because this is too much hassle


#28

Tried to execute the commands you mentioned but did not resolve the issue. Philsophy-wise I don’t agree that users should fix by themselves what developers should, especially when security could (even remotely) be compromised. Still waiting for a definitive fix.


#29

Which distribution are you using?


#30
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic

#31

This topic was automatically closed after 30 days. New replies are no longer allowed.