Unsupported command-line flag: --no-sandbox

Hi @hello-houston hopefully my suggestion works for you.

The issue persists, and more: I just recovered my wallet, and noticed that all my BAT tokens are gone.

Very, very disappointing.

Any updates on the issue ? Is it safe to use the browser ?

1 Like

If Brave does not start and shows an error about sandboxing, you may need to enable user namespaces. For security reasons, we do NOT recommend running with the --no-sandbox flag. For more info, see https://github.com/brave/brave-browser/issues/1986#issuecomment-445057361.

This does NOT work on latest brave version (lubuntu 18.10) still the same message every time I open the browser

To reiterate to anyone encountering the --no-sandbox issue on Linux, you need to try and enable user namespaces on your machine. You can find instructions on how to do that here:

You may need to reboot before the changes take effect.

If you do this and it does not resolve the --no-sandbox issue, please let us know in this thread. Please be explicit in what steps you’ve tried to resolve the issue. Thank you.

I’ve tried everything listed on that page. I’m on lubuntu 18.10, no matter what I do the same message keeps popping up at the top when opening brave browser. I tried sudo sysctl kernel.unprivileged_userns_clone=1
echo kernel.unprivileged_userns_clone = 1 | sudo tee /etc/sysctl.d/00-local-userns.conf message still comes up. I’m to the point of just using Firefox because this is too much hassle


Tried to execute the commands you mentioned but did not resolve the issue. Philsophy-wise I don’t agree that users should fix by themselves what developers should, especially when security could (even remotely) be compromised. Still waiting for a definitive fix.

1 Like

Which distribution are you using?

Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic
1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.

Sorry for anyone following this thread, it was auto-closed by the system. I’ve reopened it for further reporting/discussions. I’ll also be directing users/new reports of this issue to this thread for easier tracking.

Given the breadth of this issue, for anyone just now seeing this thread, it would be very helpful for us to include your Linux Distribution information in your reply. Additionally, for those of you who are already following this thread, please reply (or edit a previous reply you’ve made) with your distribution information as well.

We’re prepping to do a thorough investigation into a few prevalent Linux issues (this one included) that are blocking users from using Brave or using some functionality from within it. The larger the sample size of information we have the easier it will be to diagnose and/or implement solutions.
Thank you.


Hi, using ubuntu 18.04. Keep getting the “you are using an unsupported command line flag: --no sandbox. Stability and security will suffer.”

I acquired Brave from the Ubuntu software center. Any solutions?

Previous threads did not contain workable solutions for me. Also, wish Brave could have an option like Mozilla to automatically delete browser data; would save much time. Thanks

1 Like

Ubuntu 18.04.1 LTS. I snapped back last time the auto-update turned my world upside down and was happily rolling along with the old version. Today I find Brave has updated to Version 0.58.21, chucked all of my bookmarks and settings, disconnected my from my password manager, and requires that I re-trust every site for which I had lowered shields. This is very disappointing.

In other news, the sandbox flag error is gone, I think.


Hello, I’d like to first thank you for your time and attention to this issue. After installing the latest version of brave via snap store it has completely resolved the issue with the no sandbox flag. Thank you for your replies and professionalism in working to fix this problem. Very happy to be back using brave and Uninstalled opera browser with the quickness!


In my case I am using:

Operating System: Manjaro Linux
KDE Plasma Version: 5.14.4
Qt Version: 5.12.0
KDE Frameworks Version: 5.53.0
Kernel Version: 4.19.13-1-MANJARO
OS Type: 64-bit

This message has always appeared.


Same. These updates haven’t done anything in regard to that in our end, contrary to other distros.

1 Like

I’m using Manjaro Gnome and have same issue. Brave is in the main repos but it’s updates have not fixed the problem.


As mentioned in the comments on the answer of that superuser.com question, if you get the following error:

sysctl: cannot stat /proc/sys/kernel/unprivileged_userns_clone: No such file or directory

then you’re probably running a newer kernel version. The sysctl has since changed:

sudo sysctl user.max_user_namespaces=500 | sudo tee /etc/sysctl.d/00-local-userns.conf

Edit: Although the above sysctl commmand runs correctly, it doesn’t actually fix the problem with Brave - I still get the error about --no-sandbox.