Unsupported command-line flag: --no-sandbox

linux

#1

Description of the issue:
Starting Brave shows a “You are using an unsupported command-line flag: --no-sandbox. Stability and security will suffer.” messsage. GUI has changed and show a Google-Chrome style tab/appearance. I lost all my settings, including extensions, BAT settings (although I have backupped the recovery textfile). I can’t properly use Brave at the moment and had to switch to a different browser until the issue get solved.

In brave version a sandbox mode is effectively used as launch parameter. But I didn’t change anything. Maybe an update?

/snap/brave/44/opt/brave.com/brave/brave --no-sandbox --enable-tab-audio-muting --disable-domain-reliability --disable-chrome-google-url-tracking-client --no-pings --enable-features=EnableEmojiContextMenu,DesktopPWAWindowing,fill-on-account-select,NewExtensionUpdaterService --disable-features=SharedArrayBuffer,DefaultEnableOopRasterization,VizDisplayCompositor,AutofillSaveCardSignInAfterLocalSave,kAutofillServerCommunication --flag-switches-begin --flag-switches-end

Brave Version(about:brave):
0.56.12 Chromium: 70.0.3538.77 (Official Build) unknown (64 bit)

OS Details:

Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic

#2

I am getting the exact same issues on my end, plus I cannot open Brave from the Ubuntu dock.
Command line parameters : /snap/brave/44/opt/brave.com/brave/brave --no-sandbox --enable-tab-audio-muting --disable-domain-reliability --disable-chrome-google-url-tracking-client --no-pings --enable-features=EnableEmojiContextMenu,DesktopPWAWindowing,fill-on-account-select,NewExtensionUpdaterService --disable-features=SharedArrayBuffer,DefaultEnableOopRasterization,VizDisplayCompositor,AutofillSaveCardSignInAfterLocalSave,kAutofillServerCommunication --flag-switches-begin --flag-switches-end

Brave Version : 0.56.12 Chromium: 70.0.3538.77 (Official Build) unknown (64-bit)

OS : Ubuntu 18.10


#3

@deregon here here buddy. Woke up to the same thing this morning.


#4

Looking at Brave forgets EVERYthing after update. Working as intended? (referred in All settings disappeared. Brave disappeared from launcher. Opens to welcome to brave page), using:

sudo snap revert brave

has solved (it seems completely, currently checking it) the issue.

Currently checking side effects and/or if its a proper solution.


#5

Hi thanks. I tried this and it seems to have worked. It looks like it reverted to an older version but I am not sure, I closed the terminal before I had read the message properly (muscle memory or something…)


#6

Yes, snap revert is used to rollback to a previous version. Seems to be a workaround while waiting for an official response.


#7

I’m getting a similar message in Manjaro after installing it from the Manjaro software repos. I have a fresh system install as of Friday and I’m just running Brave today, for the first time.

“You are using an unsupported command-line flag: --no-sandbox. Stability and security will suffer.”


#8

Sorry for the late response everyone.
We’re aware of this and are looking into it now. See if the solution in this thread helps:


#9

It doesn’t help on Ubuntu 18.04.1.


#10

The message isn’t coming up on Brave anymore, but I don’t know if it was a one time message or if it shows up every time. I’ll have to look a little more at home to see. However, I just followed the directions in the virtual machine on this computer, and after rebooting Brave, the message is gone.


#11

The message popped back up, but after running through the terminal commands, the sandbox message went away. So far, so good.


#12

Hi @Mattches, the workaround described in the post does not work on a fresh Ubuntu installation nor does the one I found earlier while the issue persists.


#15

Same problem for me on Ubuntu 18.04.1 - very frustrating, to say the least. The last thing that I expect to have to do anymore is fix problems from a vendor-imposed update. Ugh. I love Brave and have been a major advocate amongst my peers; following this incident I’m less inclined to recommend it.

Thanks for the revert information, that helped for me. I’m concerned now that I’m either stranded on a lower version or about to be re-upgraded to the version that vaporized all of my settings. Is there any word on this problem being fixed?


#16

Same for me… The unsupported command - line flag comes up every time. I uninstalled it and then re-installed it… on Ubuntu. I really want to support Brave but for the time being am using Chromium and Firefox again… until it gets fixed.


#17

I am also getting this “–no-sandbox” notification at the top of the browser window and the Brave browser application will not launch from the gnome dock on Ubuntu 18.10.


#18

Same problems here. Just installed Brave on Ubuntu 18.04; the “no sandbox” notice appears and it will not launch from the dock. Plus, I cannot designate Brave as the default browser. (Chrome and Firefox are already installed.)

The Windows version works fine in Oracle VM VirtualBox (Windows 10).


#19

Same problem here, I’ve been patient but do not want to use other browsers-so my internet activity is curtailed.

I hoped that today’s Xubuntu update would address the issue, but it’s still the same.

Has anyone figured out how to completely uninstall Brave and its configuration files----so that a new install from scratch can be done?

I hope there is a solution-if Brave isn’t up to snuff, using an unsupported version could be worse than not using it at all.

TY.

Art


#20

Hi! I finally found a workaround after having to use Chromium for a few weeks now.

I am running Ubuntu (Bionic Beaver).

I used these commands to download a different version of Brave that seems to have fixed the problem:

https://brave-browser.readthedocs.io/en/latest/installing-brave.html#linux

These commands for Ubuntu:

curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key add -

echo "deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ `lsb_release -sc` main" | sudo tee /etc/apt/sources.list.d/brave-browser-release-`lsb_release -sc`.list

sudo apt update

sudo apt install brave-browser brave-keyring

#21

Hi @hello-houston hopefully my suggestion works for you.


#22

The issue persists, and more: I just recovered my wallet, and noticed that all my BAT tokens are gone.

Very, very disappointing.