Unsupported browser android

A brave verified publisher “archive.is” website when opened in brave browser (android version) shows “It looks like you may be using a web browser version that we don’t support”? What to do?

https://t.co/Rmc7Af1IP8?amp=1

Brave version