Unable to watch DAZN on Brave

Hi. I have a problem with watching DAZN on Brave browser.
I just installed Brave today to try it out and so far, I love the experience with Brave and wanted to stick with this going forward. So I was trying different things on the browser making sure everything worked fine. Then I found out that for some reason, DAZN does not work on the browser. Even I click on any videos, it does not play at all.

When I first logged in to DAZN it was asking if I’m willing to download something to watch videos on DAZN. I don’t remember what it was called but the pop up appeared right by the lock icon next to the search bar. Then I tried to watch any videos but no luck so far. I was wondering if this was my computer issue so I tried DAZN on Microsoft Edge and it worked just fine.

Then I was doing some research online and went into Brave settings to allow some permissions on DAZN to see it they worked. I tried allowing Flash and Autoplay and reloaded the website but still no luck. I played with setting for a bit with other permissions on but doesn’t work. I even tried turning Brave Shields off but nothing works.

My system is on Windows 10 Pro 64-bit and the Brave Version 1.1.23

Can someone please teach me how to get DAZN working on Brave?

Thanks!

@ccolinss,
Thanks for reaching out. I know that we’ve had issues with DAZN in the past but I’m not actually sure if they were resolved. Since it requires a membership, I can only test this with videos that are freely available on the site.

Would you mind telling me, if you go to https://www.dazn.com/en-US/welcome and scroll down to the “It’s fight season on dazn” area where they have a trailer – are you able to watch this trailer?

I live in Canada so it was redirected to DAZN Canada and I do not see anything called “It’s fight season on dazn”. I think there are little difference on videos they cover.

I don’t know if I can explain my situation better but when I click on a video. It shows loading circle spinning for several seconds and it disappears and video doesn’t start at all. When I tried watching the same video on Edge or Chrome, after that loading circle, usually it starts the video right away but on Brave it doesn’t.

@ccolinss,
I’m just wondering if it’s only the paid membership content that you’re unable to view or if it’s any/all videos on the site:

I tried clicking on almost all the videos on the website and nothing works.
So I don’t think it is a matter of paid videos or unpaid videos.

@ccolinss,
Thank you for confirming. Can you tell me what your Shields settings are set to for the site?

I have tried DAZN with shield on and shield off.
When it was on, it was at default setting.
“Cross-sire trackers blocked” and “Connections upgraded to HTTPS” were on and “Scripts blocked” was off. “Cross-site cookies blocked”, and “Cross-site device recognition blocked”.

@ccolinss,
Can you try clicking the “lock” icon in the address bar, then Site Settings --> Clear data and see if this resolves the issue>?

Just cleared the data and tried it again but still doesn’t work

@ccolinss,
Would you mind attempting to play a video again, then, after it fails, open the developer tools console and take a screenshot of the input found there?

Menu --> More tools --> Developer tools --> [Console]

Hey @ccolinss would it be possible to DM your login details to test? (you can reset the password afterwards)

@ccolinss I’m in Canada as well and it seems to be working for me using 1.1.23 Chromium: 79.0.3945.88 which is the latest release.

By any chance did you enable Widevine when you received the notification? DAZN is protected via DRM so you’ll need to enable Widevine. Example of the notification:

If you’re not getting a notification when visiting the website, you can enable Widebine via the following:

  • Within the URL, paste brave://settings/extensions

You should see the following setting, make sure it’s enabled:

Do the videos/play once you’ve enabled Widevine?

1 Like

@kamil I believe I enabled Widevine. When I first downloaded the browser and went into the website, it asked me whether I want to enable Widevine or not. At first, I didn’t know what it was and I neglected it. And nothing worked on the website. So I refreshed the webiste and it gave me that popup again to enable it, I enabled it at the second time. I don’t know if this is causing the whole situation here.

I also went into setting/extensions like you told me to and checked the setting. And Widevine notification was on.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.