Unable to verify w/ Gemini, Brave Rewards became zero & not claimable

First, I am unable to verify with Gemini: I have a Gemini account but it doesn’t go further after I click “verify” (like frozen!).
Second, I had been accumulating Brave Ad rewards but after attempts at verifying, the balance became zero (0). When I click Brave Rewards (triangle) icon, it shows “0” balance. But when I click on settings, it shows my last balance, which is not “0”. Why is that?
Third, I’m also unable to link rewards to Gemini when I click that option.
Fourth, I’m also unable to claim my rewards since I started trying to verify & link with Gemini wallet. I used to be able to claim them, but now I have rewards from back in May 2022 that I could not claim.

When I type brave://rewards-internals/ on new tab to get wallet payment ID, this info shows:
Wallet info: Wallet was not yet created
Balance info: Total balance 0 BAT
External wallet info: Wallet status: Not connected
No Wallet Payment ID is showing.

Please help and advise how to proceed so it works,
GR

Hi and welcome to the community. Can you please provide the following information that will help community members (like me!) and/or Brave support staff troubleshoot your issue.

Source: Support Templates Reference - #3 by Mattches

  1. What Operating System and Brave version are you using (can find at brave://version)?

  2. Have you been able to successfully receive payments to Gemini in the past?

  3. Are you in a supported region (see here for list of supported regions)?

  4. Does your device pass the SafteyNet check (Android only)?

Also, are you getting any error messages and what are they? Can you provide a screenshot?

Please post an update.

Hello Chocoholic,

Thanks for your email.
Please see my answers below in RED.

Kind regards,
GR

Oops. Looks like the information is missing from your post. Can you please update again. You can just edit your above post and add the information or you can post a new reply.

Thanks! Take care. :slightly_smiling_face:

Duh. Just realized you probably had options set in preferences to send emails. I don’t use this option and didn’t even occur to me! Too funny. :rofl:

I’m editing my post. :grin:

I’m totally confused. Are you kidding? Why is it funny? Are you Chocoholic? Are there two of you? Are you still able to help me with my issue anyway?

Hello,
The issue got resolved by itself. I could suddenly verify & link Brave Rewards to Gemini account so now, all is good. Thanks anyway.