Unable to Update Brave to Latest Version

For the past few months I’ve been unable to update my Brave browser, version 1.57.53 Chromium: 116.0.5845.114 (official build) 64 bit on my Dell laptop running Ubuntu 22.04.3 LTS. Whenever I try to update using Terminal or Synaptic Package Manager I receive the following error message:

Could not download all repository indexes

The repository ‘https://ppa.launchpadcontent.net/gezakovacs/ppa/ubuntu jammy Release’ does not have a Release file.Updating from such a repository can’t be done securely, and is therefore disabled by default.See apt-secure(8) manpage for repository creation and user configuration details.Skipping acquire of configured file ‘main/binary-i386/Packages’ as repository ‘https://brave-browser-apt-release.s3.brave.com stable InRelease’ doesn’t support architecture 'i386’The repository ‘https://deb.etcher.io stable Release’ does not have a Release file.

I posted this issue on the Ubuntu Mate Forum and charles-nix replied with these instructions:

The Brave issue is that Brave no longer issues an i386 version. I can’t say why your sources.list specifies one, but it doesn’t matter. You don’t need to reinstall all the software, you need corrections to your file that tells synaptic/apt where to find the software packages.

You can do everything about the Brave you need in a few seconds, within Synaptic, on the repositories lines. Just change to match what is on the link reference on the brave forum. Then reload repositories, then update. In Synaptic, choose Settings > Repositories. Then Other Software tab, and highlight the repository affecting Brave. Make the line look like the sample linked after the deb part – meaning add the [arch=amd64] and that should be it. Or, you may have some reference locking into i386 in the same line that needs deleting. Close, reload repositories, update and you should be good.

Where can I find the link reference on this forum that charles-nix is referring to?

Hello @synapticity

this official repo https://brave.com/linux/#debian-ubuntu-mint

not sure if you installed brave using snap of the above method?

Thanks justsomeone!, I tried editing the repository line but the button is grayed out so it doesn’t do anything when I click on it. Why isn’t Synaptic allowing me to edit the link reference?

sorry for the miss understanding i ment to say that the link i shared has the official repo

the official repo is https://brave-browser-apt-release.s3.brave.com/ which you already mentioned and it what mentioned also on the link i provided earlier

could you run the 5 commands on the following link https://brave.com/linux/#debian-ubuntu-mint

I ended up unchecking ‘https:deb.etcher.io stable etcher’ and I was able to update Brave to Version 1.59.120 and Chromium 118.0.5993.88 so my problem is now officially solved! Thank you for your suggestions, I appreciate it!

1 Like

A few comments:

First, I’m using Debian which, while similar to Ubuntu, isn’t the same. Which leads to:

Second, I’m glad you’ve found what appears to be an interim solution. Interim because:

Third, at this moment, the current version of Brave is 1.59.124 which was offered to me a few days ago. From what I can tell, the major changes between 1.59.120 (what you say you’ve installed) and .124 are a Chrome update and (perhaps more important) improved updating of Ad Block Resources.

I suggest: be alert to whether you’re timely offered future updates. If ‘yes’, you’ve resolved your issue. If ‘no’…

The next announced update to v1.60.x is November 2, 2023, but adhering to this schedule can be a bit squishy.

Good luck.

glad to know that you figured it out and you welcome :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.