Unable to sync a specific linux system

I have six linux systems (LinuxMint 21.3), all configured pretty much identically. I have Brave sync set up and it works successfully with all of the systems – and with my Android mobile – except for one of the linux systems.

After adding Brave to the system and setting up sync, it then shows the system in the device list on that system. But that system does not appear in the list on any of the other three systems. Nor, does any of the items I’ve checked for syncing on that system get sync’d.

I confirmed that all systems have the same version of Brave (1.64.113). I tried removing Brave and removing the .config/BraveSoftware directory, rebooting, installing Brave and setting up sync again but still no success.

What else can I check or try? Would it be worth deleting the entire sync chain and creating a new one?

@IronRod are you being given any particular error messages?

Also have to ask, do you have keychain set for Brave? Brave uses your OS keyring for encryption. I know have been issues on things syncing or Brave saving your passwords if Brave doesn’t have access. You can check on this similar to as discussed in link below:

All of the systems have the same administrator-level login so have the same permission levels, etc.

The name of the system with the issue is “ardor”. Brave on ardor thinks everything is happy(?) – no errors, and under “Device list” it displays “ardor (This Device)” with the date it was added.

But looking at the device list in Brave on any other system, ardor is not listed. On all my Brave installs, I select Bookmarks, Extensions, History, Settings, and Theme – but none of these are being sync’d to ardor.

Yes, the key ring is being used. I am using the following statements – from the page Installing Brave on Linux – to make the initial install of Brave:

sudo curl -fsSLo /usr/share/keyrings/brave-browser-archive-keyring.gpg https://brave-browser-apt-release.s3.brave.com/brave-browser-archive-keyring.gpg

echo "deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main"|sudo tee /etc/apt/sources.list.d/brave-browser-release.list

sudo apt update

sudo apt -y install brave-browser

Okay, so I just was mentioning basics. I know nothing on Linux. Let me tag in @Mattches on it as he’s the expert.

Other thoughts:

  • I have also tried selecting [Leave Sync Chain] from ardor. This temporarily removes it from the Device List viewed in Brave on ardor. But after closing Brave and re-opening, ardor is back in the list. (That certainly feels like some kind of permission-related issue.)
  • All of the other systems have been running Brave for a while, some for many months and have each received several updates of Brave during that time. ardor was just built yesterday so is a new install. But, as mentioned, all are running the same version 1.64.113
  • I wonder if not having installed an earlier version on ardor (as was done with all the others) that something didn’t happen by just installing the latest version; i.e., something changed in a later version (or this version) that might cause this? Maybe uninstall this version, install one from a month or two ago from here, and then upgrade?

UPDATE
This morning, I checked and ardor now appears in the device lists on all systems and appears to be sync’ing. I have made no changes at all. And it now appears with an added date of today, even though I actually added it yesterday.

I’ll continue to monitor but it seems okay now. After a few days of continued success, I’ll report back.

1 Like