Unable to successfully connect to wify network

everytime I lose connection I go to my wify and fill in password and then I get this message Bad Request - Request Too Long

HTTP Error 400. The size of the request headers is too long.

I have had to go to another browser to log in and restore a connection on it and then I can go back and use Brave.

@dcooper,

Do you mean that you login to your routers wifi settings on your network (usually done by entering the router’s IP into the address bar)?

I am on a network and have to sign in to hook up to the wify. I cannot do this on BRAVE … I get an ERROR MESSAGE every single time…what I have been doing is opening my old Firefox browser clicking on the Linksys Smart Wi-Fy link and entering the information to get connected then I go back to Brave.

I select the network I want to connect to and then enter the password

But when I do this on BRAVE I get an ERROR MESSAGE as posted in my first message every single time.

@dcooper,
This would depend on the network in which you’re attempting to login to. I assume this is a public network? Regardless, I’ll need more information to help you.

This network is all within a 2 BR apartment. In order for me to access the wi-fy network I have to enter a password which I can do with no issues when I am using Firefox but every time I attempt to when using Brave I get the previously described error message

  • What kind of operating system are you using?
  • Are you connecting through a VPN?
  • Any extensions installed? Especially any that may monitor or control network activity?
  • Have you tried to do this in Brave with Shields down?

This is why it’s important to follow the template/guidelines so that we can bypass boiler-plate support questions such as these.

Windows 10 and no VPN
I am not techy enough to know about extensions.
There is nothing I am aware of that controls network activity that would impact Brave and not google chrome, opera or firefox
I think I tried both ways when it first became an issue.
I only have to do re-connect when I get ‘kicked off’ the network which may happen several times in a 4 hour time period or not once in 24 hours. I tried once this morning & failed so I have been using Firefox until I just went to check messages