Unable to send funds out of brave wallet

no hash. unable to view on block explorer. cant send from brave interface or use dapps on eth mainnet

Haha, I understand Brian. If you didn’t have a million other things to balance on top of trying to help here on the forums, it might be a different story. Though I do wonder if you almost wouldn’t prefer to be able to do nothing but sit here on the forums for a day rather than all the other things you’re doing “behind the scenes” on a daily basis.

Anyway, let me slip out of here since this isn’t my post or problem. I just was trying to help them get in touch with the right person. Definitely will be trying to watch this and learn as it’s all foreign to me. But hopes are as I see you guys do things and learn, I’ll be able to help more and alleviate some of it from you guys.

1 Like

I have a couple of ideas for you to try.
Maybe there’s an issue with the nonce value.
In 1.36.x in brave://settings/wallet we have a “Clear wallet transaction and nonce information” option. I’d recommend trying that but you’re still on 1.35.x

If you are willing to, you could go to the menu on the top right and Create a new profile. Then restore your wallet seed there in the secondary profile. Then see if you can send from the 2nd profile.

Otherwise if you’re willing to wait until 1.36.x you could try that option too.

1 Like

ive done the second idea still no effect. any release info on 1.36.x

Please send me an email at brian@brave.com if you are willing to and we can setup a Zoom call at an agreeable time where you can share your screen and we can troubleshoot together. I think that’s the next step here to try to get more information about what’s going on. Please add a link to this community post in the email.
Thank you for helping troubleshoot and not giving up at sight of a problem!

2 Likes

Updating here, we did a Zoom call and found out 2 things.

  1. Our UI is a bit confusing because it looks like the error is because of the warning about the checksum, but the button is actually disabled because the balance is 0. We’re going to add a hover tooltip over the Send button to explain why it’s disabled or do something similar.

  2. Dropped transactions are hard to find in our UI and then all future transactions won’t work.
    A dropped transaction can happen for example if gas fees are way too low and the mempool of miners is full otherwise. We could add a Dropped state and surface those transactions better and re-use their nonce values.
    This is also solve-able by the feature in 1.36.x in chrome://settings/wallet to reset your local transaction and nonce information. I posted this to track the improvements: https://github.com/brave/brave-browser/issues/21051

2 Likes

Okay cool thanks so that feature will be on the next update?
There are funds in my wallet and trying to cancel transactions submitted transactions (I figured those are the dropped ones? the other transactions just show error) doesn’t work. Doesn’t show up on etherscan or anything.

Thanks

1 Like

Yep. The best way to clear out those transactions will be via 1.36.x in the next update.
The other UI enhancements to make things less confusing when you had a stuck transaction and for not allowing 0 value transfers will be in subsequent updates after that.

Awesome thanks for the help Brian.

Cheers.

have you had this problem solved yet? because i’ve been having the same issue and seems the the hole brave community just ignores it, if i was running a company i think i would try to keep my customers happy and not lock there money away where they cant touch it or get any help about it, are these people working for justin trudeau or something? just ignore it untill it goes away? or are we gonna get some sort of help with are money soon?? @Brave-Browser-Fanboy @Mattches

@Saoiray @iconicshade

No I havent, but a solution should come with the next update whenever that is. Read through the last bit of the thread.

so i have to wait for the next update to get access to my funds? thats unacceptable

Nope, new update already is out so you should be able to do it. Assuming you’re using desktop anyway.

Would that be reset wallet in the settings then? My browser is still showing 1.35.

I reset the wallet and used my seed and all my funds are gone. Not sure what happened. Lost over 1.7 Eth.

@iconicshade Are you on desktop? If so, new update rolled out yesterday and you might just need to update. https://brave.com/latest/

Mobile devices are still on 1.35 and 1.34 (Android and iOS, respectively)

I had seen the above, plus his post from before which I’m quoting/showing below.

If you check in https://brave.com/latest/ you’ll see where it shows all the updates/changes they made on the browser. The majority of things were fixes to Brave Wallet. Not sure how many apply to you. I’m kind of dumb/ignorant when it comes to Brave Wallet and everything associated. I just had responded in regards to where y’all mentioned the next update, as I can confidently say that’s arrived (on Desktop anyway)

Yes I am on desktop. It shows 1.35.1. I never got an update but i reset the wallet and its a new address and all my funds are gone. I lost almost 4 eth actually I think. Not sure what happened. maybe I used a wrong seed.

Yeah, means you need to update.

Im pretty sure I used the correct seed I’m not sure what happened. Wallet address got changed and now I dont have access to my old wallet.

0xf18602fA1D92ba5101ebA347f4C07ceb3fFfA884 is my old address but I’m locked out now.