Unable to select country unresolved

i am not having the same problem on my laptop or android phone, only desktop.

The message you’re getting there is based off of your region and/or regional format of the operating system you’re using. DO you happen to have it for something like Russia or Russian? Example of this can be found in a little FAQ thing I wrote for people getting that error, which you can read at PSA: Current FAQ - #16 by Saoiray

The only possible downfall might be in getting bookmarks or things over. But you can always sync your profiles with each other if need be. And since wasn’t able to select country on normal profile, it’s not like you have any BAT to lose. Definitely would just go with the new profile and see what happens. You should be good.

Thank you. I’m not really sure how it would’ve changed to another country as i have never changed it on my own. How can i tell which country it is currently in?

checked my PC settings and I am set to Canada

For everything? Region, Regional Format, and Language? (Language is one lately people have been saying can be a problem, otherwise was country/region and regional format)

@mucker Oh, shoot. Sorry, I had to read back again. The one about changing the region was for Vark. They ended up with that message saying their region wasn’t supported. Since you haven’t seen this on the new profile or your old, then the solution I gave them doesn’t apply.

For your situation it’s as I shared with your comment quoted, it’s that you’ll need to do the new profile, as it seems something just went haywire on your original. But you did mention when you created a new browser profile, it allowed you to select a country, right?

yup i did create a new one. Will there be a way to import bookmarks to a new profile?

@mucker Yeah, you can do it all one of two ways.

  1. You can create a sync chain and add the profiles to it.


  1. Just go to Bookmarks at brave://bookmarks/ and choose to Export Bookmarks. You can do the same with passwords and all.

Honestly, sync is probably quicker/easier, but you can do whichever.

i managed to sync my new profile to old one so i should be good to go, thank you very much for the help!

i spoke to soon. Now that i have synced i can no longer select country in the rewards tab on my new profile.

@mucker Hmm, weird. But bigger thing, did you not choose country first? Should have done that and then synced after. At least if you’re having that issue, it means there’s something in your settings. Do you have any extensions installed that also is now on your new profile?

Could bookmarks be interfering?
I hope I’m not sounding like an absolute id iot

i really don’t know, how would i test that? I would really like this fixed as |I am missing out on earning my BAT

Make a new profile again and delete the other new one you made. Make sure you don’t delete the original one (where you have bookmarks and other data stored). Select the region first and then connect to Uphold/Gemini and only then sync the original profile and the other one.

Wait till @Saoiray replies here. He could have better ideas than me lol.

thank you, I will wait then and see if he agrees.

99.99% should have nothing to do with it.

You didn’t answer my question. Did you end up syncing first and then tried to choose country? If so, start over and do New ProfileChoose countrySync profiles. Should be fine at that point, assuming you were right before and it was letting you select a country.

However, if new profile DOES NOT let you pick a country, then we’ll be back at step 1. But I’m going off of what you were saying at Unable to select country unresolved - #8 by mucker

i will give that a try and get back to you. Thank you

1 Like

Well Saioray, it seems to have worked! I now have my uphold wallet working as well. I can now delete the profiles I made and just keep the new one?

Yep, if you have bookmarks and all situated, feel free to delete the prior profile. Otherwise, might want to make sure to get everything kind of moved over unless you’re just wanting to start everything from scratch.