Unable to run the latest version of Brave on Arch-Linux

After doing a full system upgrade sudo pacman -Syyu, then when I tried to install it from the AUR yay -S brave-bin then after installation I get this error in the terminal when I tried to launch it:

fish: “brave” terminated by signal SIGTRAP (Trace or breakpoint trap)

Any ideas what may be happening?

Brave is running fine on my Arch install. Did you try installing it the “Arch way,” makepkg -si ?

No, as stated I installed it via this command yay -S brave-bin. I did not do makepkg -si which means it is not built from source, it is already precompiled in the AUR. So however precompiled it have screwed up somewhere.

I haven’t got a Arch install handy, but if you start Brave from a clean profile (rename the old). Does it help?

Would you happen to know how I would do this?

I typed in terminal brave to launch the executable and I get an output error message:

fish: “brave” terminated by signal SIGTRAP (Trace or breakpoint trap)

So if you happen to know how to fix this this will be great mate, thanks :slight_smile:

Was testing in ubunutu, Not sure if applicable in Arch. I’m not sure if this will resolve it, but its worth a try I guess.

cd ~/.config
mv BraveSoftware BraveSofware-bak

And to revert, close Brave, cd ~/.config, delete BraveSoftware folder and mv -f BraveSofware-bak BraveSoftware (this is basically reverting it)

You can install brave-bin from the AUR without using a helper. The AUR helper may be causing your issue.

git clone https://aur.archlinux.org/packages/brave-bin/
cd brave-bin
makepkg -si