Unable to open ads from notification area

ads-bug
#1

Description of the issue:

When ad banners are listed in the Notification Area, clicking on them dismisses them without opening them in the browser.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Disable “show notification banners” for Brave notifications.
  2. Await ad notifications.
  3. Click on ad notification in Notification Area.

Actual Result (gifs and screenshots are welcome!):

Notification is dismissed.

Expected result:

Opens ad in browser.

Reproduces how often:

Consistent.

Brave Version(about:brave):

Brave is up to date
Version 0.63.11 Chromium: 73.0.3683.75 (Official Build) dev (64-bit)

Reproducible on current live release (yes/no):

yes (dev release)

Note: this has not been addressed by the macOS issue noted in my previous post.

1 Like

#2

:slightly_frowning_face:
No response after 3 weeks?

0 Likes

#3

@rivy Thanks for reporting. Unable to reproduce the issue on Windows 10 x64 with brave version 0.64.37. I am able to open the Ads notification from notification center.

Can you test it on latest Dev build and revert back if it doesn’t work.

Thanks!

0 Likes

#4

@gsarvadnya , thanks for taking the time to look into this issue.

The broken behavior is consistent regardless of version.

I’m, now, currently on:

Brave is up to date
Version 0.64.47 Chromium: 74.0.3729.61 (Official Build) dev (64-bit)

The best way to reproduce for me is:

  1. Use usual notifications.
    • Clicking on the “live” notification banner does bring up the ad in this case.
  2. Enable “Focus Assist” to “Alarms only”.
    • In this mode, a small half moon is displayed as as overlay on top of the notification icon in the lower right corner. And, with this setting, the notifications are “hidden” directly into the notification area without a “live” banner.
    • Clicking on any of these notifications within the notification slide out just dismisses the banner without opening brave or displaying the ad.

I have tried various brave versions, including non-dev versions, and they all have to same broken behavior. I can see the add banners (within the notification slide out) but can never get the ad to display when clicked.

0 Likes

#5

@rivy Thanks for the additional information. I am able to reproduce the issue. Will file an issue shortly. Please track the below issue.

Thanks!

0 Likes

closed #6

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes