Unable to make Brave Beta default app

Unable to set Brave as default browser in Windows 10

Reset Windows 10 default apps, when I choose ‘web browser’ to choose the intended web browser, I only see Edge, Internet Explorer and the Windows Store as options.

Capture

Can you try via Brave Settings > Get started? There should be a setting to set default.

Thanks, that worked after a reboot of my computer.

It seems that after the Brave Beta install, it needed a reboot for the default app list to show the browser.

1 Like