Unable to login to "Zalando" and "Asos"

Hello,

I’m unable to login to my Zalando and Asos accounts with Brave.

The Zalando form returns “An error occured.”
The Asos form returns “Sorry, you can’t access your account for now.”

I tried to:
-Disable Brave Shields on “zalando.com” and “accounts.zalando.com
-Disable Brave Shields on “asos.com” and “my.asos.com
-Delete all cookies and cache
-Navigate in private mode
-Create a new profile without any extension

None of these work.
There is no issue with Chrome, Firefox or Edge for both accounts.

Brave version: 1.39.111

Regards

Hey @Deaudouce

Just tested asos.com, (new sign up). Not using a VPN or secureDNS?

Hello,

No I don’t use any VPN or custom DNS…!

Regards

@Deaudouce

At: https://www.zalando.com/ the browser window shows icons representing several countries - none of which are the USA.

The URL address for each of the represented countries, ends with the respective country’s two-letter code; for example:

  • France: .fr
  • United Kingdom: .uk

Let us say, that you are in England or in France. The Zalando.com websites:

  • https://www.zalando.co.fr/
  • https://www.zalando.co.uk/

Login [button] will redirect to: https://accounts.zalando.com/ . . . (a lengthy, authentication URL address).

In a Brave Browser - New Window, go to: brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter accounts.zalando.com:443 as the site . . . but Do Not Enable

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Repeat those steps for:

  • [*.]zalando.co.fr:443
  • [*.]zalando.fr:443
  • [*.]zalando.co.uk:443
  • [*.]zalando.com:443

If you encounter a reCAPTCHA, add these:

  • www.google.com:443
  • www.gstatic.com:443

While at: brave://settings/cookies

  • Enable: Block third-party cookies
  • Disable: Clear cookies and site data when you close all windows
  • Remove all: Sites that clear cookies when you close them

Next, go to: brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter accounts.zalando.com:443 as the site . . . but Do Not Enable

  • Current Private session only

Click the Add button

Repeat those steps for:

  • [*.]zalando.co.fr:443
  • [*.]zalando.fr:443
  • [*.]zalando.co.uk:443
  • [*.]zalando.com:443
  • [*.]ztat.net:443

If you encounter a reCAPTCHA, add these:

  • www.google.com:443
  • www.gstatic.com:443

Recommended in order to reduce influence by websites:

In a Brave Browser - New Window, go to: brave://settings/content

Scroll down to “Additional permissions” . . . and set:

  • Protocol handlers: Don't allow sites to handle protocols
  • File editing: Don't allow sites to edit files or folders on your device
  • Clipboard: Don't allow sites to see text or images on your clipboard
  • Window placement: Don't allow sites use info about your screens to open and place windows

Scroll down to “Content” . . . and set:

  • Pop-ups and redirects: Don't allow sites to send pop-ups or use redirects

Cookies check

In a Brave Browser > New Window, go to: brave://settings/cookies and in the upper-right area of the window, enter into the Search field: zalando

Then, search down the cookies settings page and check to see if zalando shows under Sites that can never use cookies . If exists, then remove the zalando entry.

JavaScripts check

In a Brave Browser > New Window, go to: brave://settings/content/javascript and in the upper-right area of the window, enter into the Search field: zalando

Then, search down the javascripts settings page and check to see if zalando shows under Not allowed to use javascript. If exists, then remove the zalando entry.

Thanks for the answer!

I tried your instructions, using “zalando.fr” as I live in France.
Unfortunately, I performed and checked twice your steps, but it still does not work.

I also checked if there was any network error returned in the developer tab.
If it is useful for you, the “/api/login” request returns a 403 error with the following response:

{
  "edge_error": "halt",
  "ref_id": "[...A long id...]",
  "wait": 60,
  "feedback": {
    "email": true,
    "url": "",
    "recaptcha": {
      "enabled": false,
      "type": 0,
      "sitekey": ""
    }
  }
}

Do your instructions work for you when you try to login?

Regards

@Deaudouce

I do not have an account.

I updated my earlier reply with more info and possible steps for you to consider.

@289wk

Thanks for the update.
I did everything, but unfortunately there is still the same issue.

I really don’t understand why it does not work. These are the only two websites where I have this login issue. And again, there is no issue at all with all other browsers I tried.

(By the way, the domain “zalando.co.fr” does not exist at all, it is just “zalando.fr” for France).

Regards

1 Like

I only can tell you that I have the same problem with zalando, but no solution.

very strange.

I just tried to login to both sites with Brave from my Android phone:

So the problem on “zalando” seems to be caused by Brave itself, and the problem on “asos” seems to be caused by a specific configuration on the desktop version. However, I don’t understand where this is coming from, as I don’t use any specific settings or VPN.

Regards